summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-02-01 18:27:40 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-02-05 22:33:56 +0100
commit3f4ecf6649b733d50b11acb941d16b7505fdb93e (patch)
tree37e48afbf5ad0750a224ccd987370d82dc7f0695 /gnu/packages/ocaml.scm
parent6a1140012c9791e9ef3137280baf04254b4409d2 (diff)
downloadpatches-3f4ecf6649b733d50b11acb941d16b7505fdb93e.tar
patches-3f4ecf6649b733d50b11acb941d16b7505fdb93e.tar.gz
gnu: Add ocaml-ppx-optional.
* gnu/packages/ocaml.scm (ocaml-ppx-optional): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a8176c27ca..7f208a8888 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5616,3 +5616,31 @@ context such as function arguments.")
(description "A ppx rewriter that inlines reverse application operators
@code{|>} and @code{|!}.")
(license license:asl2.0)))
+
+(define-public ocaml-ppx-optional
+ (package
+ (name "ocaml-ppx-optional")
+ (version "0.11.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
+ (version-major+minor version)
+ "/files/ppx_optional-v" version ".tar.gz"))
+ (sha256
+ (base32
+ "1z8z2bga95k2vksljljfglg10vygkjd24kn1b37sk4z3nmp47x0h"))))
+ (build-system dune-build-system)
+ (arguments
+ ;; No tests
+ `(#:tests? #f))
+ (propagated-inputs
+ `(("ocaml-base" ,ocaml-base)
+ ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+ ("ocaml-ppxlib" ,ocaml-ppxlib)))
+ (properties `((upstream-name . "ppx_optional")))
+ (home-page "https://github.com/janestreet/ppx_optional")
+ (synopsis "Pattern matching on flat options")
+ (description
+ "A ppx rewriter that rewrites simple match statements with an if then
+else expression.")
+ (license license:asl2.0)))