summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorgabrielhdt <gabrielhondet@gmail.com>2019-05-03 20:25:04 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-05-03 20:46:22 +0200
commit187f9636f176d62bf869b787ad410e3a528aa1a0 (patch)
tree4fb46ed90d211c8ed7e4c43f6baf0f2ca6d5c3c9 /gnu/packages/ocaml.scm
parent52c3cb2687d93ba6444412e67b8b3e9e95627066 (diff)
downloadpatches-187f9636f176d62bf869b787ad410e3a528aa1a0.tar
patches-187f9636f176d62bf869b787ad410e3a528aa1a0.tar.gz
gnu: ocaml-menhir: Update to 20181113.
* gnu/packages/ocaml.scm (ocaml-menhir): Update to 20181113. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm34
1 files changed, 16 insertions, 18 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 33acbbec4e..6e69be3f19 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -756,35 +756,33 @@ Emacs.")
(define-public ocaml-menhir
(package
(name "ocaml-menhir")
- (version "20161115")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "http://gallium.inria.fr/~fpottier/menhir/"
- "menhir-" version ".tar.gz"))
- (sha256
- (base32
- "1j8nmcj2gq6hyyi16z27amiahplgrnk4ppchpm0v4qy80kwkf47k"))))
- (build-system gnu-build-system)
+ (version "20181113")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.inria.fr/fpottier/menhir.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1iqdf64ayq4s3d9jkwhs3s8wqc2s48b292hp0kcjsskfhcvwg0kr"))))
+ (build-system ocaml-build-system)
(inputs
`(("ocaml" ,ocaml)))
(native-inputs
`(("ocamlbuild" ,ocamlbuild)))
(arguments
- `(#:parallel-build? #f ; Parallel build causes failure
+ `(#:make-flags `("USE_OCAMLFIND=true"
+ ,(string-append "PREFIX=" (assoc-ref %outputs "out")))
#:tests? #f ; No check target
#:phases
(modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (setenv "PREFIX" out))
- #t)))))
- (home-page "http://gallium.inria.fr/~fpottier/menhir")
+ (delete 'configure))))
+ (home-page "http://gallium.inria.fr/~fpottier/menhir/")
(synopsis "Parser generator")
(description "Menhir is a parser generator. It turns high-level grammar
specifications, decorated with semantic actions expressed in the OCaml
-programming language into parsers, again expressed in OCaml. It is based on
+programming language into parsers, again expressed in OCaml. It is based on
Knuth’s LR(1) parser construction technique.")
;; The file src/standard.mly and all files listed in src/mnehirLib.mlpack
;; that have an *.ml or *.mli extension are GPL licensed. All other files