summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2020-01-06 20:57:28 -0600
committerBrett Gilio <brettg@gnu.org>2020-01-06 20:57:28 -0600
commitd977e243644c3ce6c6e7dc682b09ae409fcd8077 (patch)
tree69e7f336a0f6b0e183c93c63da43a305cf8f8958 /gnu/packages/ocaml.scm
parent136919ba4976ec20bbfbd14587e87c4780653226 (diff)
downloadpatches-d977e243644c3ce6c6e7dc682b09ae409fcd8077.tar
patches-d977e243644c3ce6c6e7dc682b09ae409fcd8077.tar.gz
gnu: Add lablgtk3.
* gnu/packages/ocaml.scm (lablgtk3): New variable. Co-authored-by: Julien Lepiller <julien@lepiller.eu>.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 738706b23f..3253d0285a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5273,3 +5273,48 @@ with support for multiple output devices. Currently supported output targets
include the X Window System, Quartz, Win32, image buffers, PostScript, PDF,
and SVG file output.")
(license license:lgpl3+)))
+
+(define-public lablgtk3
+ (package
+ (name "lablgtk")
+ (version "3.0.beta8")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/garrigue/lablgtk.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "08pgwnia240i2rw1rbgiahg673kwa7b6bvhsg3z4b47xr5sh9pvz"))))
+ (build-system dune-build-system)
+ (arguments
+ `(#:tests? #t
+ #:test-target "."
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'make-writable
+ (lambda _
+ (for-each (lambda (file)
+ (chmod file #o644))
+ (find-files "." "."))
+ #t)))))
+ (propagated-inputs
+ `(("ocaml-cairo2" ,ocaml-cairo2)))
+ (inputs
+ `(("camlp5" ,camlp5)
+ ("gtk+" ,gtk+)
+ ("gtksourceview-3" ,gtksourceview-3)
+ ("gtkspell3" ,gtkspell3)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/garrigue/lablgtk")
+ (synopsis "OCaml interface to GTK+3")
+ (description "LablGtk is an OCaml interface to GTK+ 1.2, 2.x and 3.x. It
+provides a strongly-typed object-oriented interface that is compatible with the
+dynamic typing of GTK+. Most widgets and methods are available. LablGtk
+also provides bindings to gdk-pixbuf, the GLArea widget (in combination with
+LablGL), gnomecanvas, gnomeui, gtksourceview, gtkspell, libglade (and it can
+generate OCaml code from .glade files), libpanel, librsvg and quartz.")
+ ;; Version 2 only, with linking exception.
+ (license license:lgpl2.0)))