summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-05-28 15:30:33 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-06-06 21:10:00 +0200
commit9059d856d27c7ea538f6b2feecf95c4da0011e21 (patch)
tree3a2247d5b2735350ffd1206ecbe6b7ccac820acd /gnu/packages/ocaml.scm
parent84470902dcb273681e927abd304f74a8fb5c75b1 (diff)
downloadpatches-9059d856d27c7ea538f6b2feecf95c4da0011e21.tar
patches-9059d856d27c7ea538f6b2feecf95c4da0011e21.tar.gz
gnu: Add ocaml-ocplib-endian.
* gnu/packages/ocaml.scm (ocaml-ocplib-endian): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 5acf06d767..3e8337518c 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3065,3 +3065,26 @@ async library.")
(synopsis "Monadic concurrency library")
(description "Async is a library for concurrent programming in OCaml.")
(license license:asl2.0)))
+
+(define-public ocaml-ocplib-endian
+ (package
+ (name "ocaml-ocplib-endian")
+ (version "1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/OCamlPro/ocplib-endian/"
+ "archive/" version ".tar.gz"))
+ (sha256
+ (base32
+ "0hwj09rnzjs0m0kazz5h2mgs6p95j0zlga8cda5srnzqmzhniwkn"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system ocaml-build-system)
+ (native-inputs `(("cppo" ,ocaml-cppo)))
+ (home-page "https://github.com/OCamlPro/ocplib-endian")
+ (synopsis "Optimised functions to read and write int16/32/64 from strings
+and bigarrays")
+ (description "Optimised functions to read and write int16/32/64 from strings
+and bigarrays, based on new primitives added in version 4.01. It works on
+strings, bytes and bigstring (Bigarrys of chars), and provides submodules for
+big- and little-endian, with their unsafe counter-parts.")
+ (license license:lgpl2.1)))