summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-05-28 15:13:50 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-06-06 21:09:46 +0200
commitcf28a731c63f3985929b377e8647808e62daaf40 (patch)
treef05a1f1d9afaf3a999deb5e97637deec652cf841 /gnu/packages/ocaml.scm
parente31ee74d911b96a608fceaaeb338324851d350e4 (diff)
downloadpatches-cf28a731c63f3985929b377e8647808e62daaf40.tar
patches-cf28a731c63f3985929b377e8647808e62daaf40.tar.gz
gnu: Add ocaml-async-rpc-kernel.
* gnu/packages/ocaml.scm (ocaml-async-rpc-kernel): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index d526b825c4..f360e7d1f0 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2959,3 +2959,24 @@ the full Core is not available, such as in Javascript.")
(synopsis "Monadic concurrency library")
(description "Async-kernel is a library for concurrent programming in OCaml.")
(license license:asl2.0)))
+
+(define-public ocaml-async-rpc-kernel
+ (package
+ (name "ocaml-async-rpc-kernel")
+ (version "113.33.03")
+ (source (janestreet-origin "async_rpc_kernel" version
+ "0y97h9pkb00v7jpf87m8cbb0ffkclj9g26ph6sq97q8dpisnkjwh"))
+ (native-inputs
+ `(("oasis" ,ocaml-oasis)
+ ("js-build-tools" ,ocaml-js-build-tools)
+ ("ppx-jane" ,ocaml-ppx-jane)
+ ("opam" ,opam)))
+ (propagated-inputs
+ `(("async-kernel" ,ocaml-async-kernel)))
+ (build-system ocaml-build-system)
+ (arguments janestreet-arguments)
+ (home-page "https://github.com/janestreet/async_rpc_kernel/")
+ (synopsis "Platform-independent core of the Async RPC library")
+ (description "Async_rpc_kernel is the platform-independent core of
+the Async RPC library.")
+ (license license:asl2.0)))