summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:14:03 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:37 +0200
commitf4f3e8ce4d2a63855e081faae2b7d25730d8bd88 (patch)
treea197dc7e73feb72aad20004e6b532c292f92692d /gnu/packages/ocaml.scm
parent55f9f9b081804c69df49e9689975cf8758e8b0a1 (diff)
downloadpatches-f4f3e8ce4d2a63855e081faae2b7d25730d8bd88.tar
patches-f4f3e8ce4d2a63855e081faae2b7d25730d8bd88.tar.gz
gnu: ocaml-zed: Don't use unstable tarball.
* gnu/packages/ocaml.scm (ocaml-zed)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index d4ff8649a9..42e543fbb0 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4369,14 +4369,15 @@ is provide a description of your project and Jbuilder will do the rest.")
(package
(name "ocaml-zed")
(version "1.6")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/diml/zed/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "19m5vrj60vg1b63qfsv0aabdlzgn40cqmx65s3wafqi4fs9xp6jn"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/diml/zed.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00hhxcjf3bj3w2qm8nzs9x6vrqkadf4i0277s5whzy2rmiknj63v"))))
(build-system ocaml-build-system)
(arguments
`(#:phases