summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:13:47 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:36 +0200
commit677a88e075e66bae1eca285a4da7d57b8179b62e (patch)
tree216ceb827b7d8b3ee4a358f6cc4ddc92be5d2bce /gnu/packages/ocaml.scm
parent554d98db7767ad5749ff5f1f010201e417ae6ad5 (diff)
downloadpatches-677a88e075e66bae1eca285a4da7d57b8179b62e.tar
patches-677a88e075e66bae1eca285a4da7d57b8179b62e.tar.gz
gnu: ocaml-piqilib: Don't use unstable tarball.
* gnu/packages/ocaml.scm (ocaml-piqilib)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 3a709de61f..5501d16093 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4064,14 +4064,15 @@ cpp-like directives.")
(package
(name "ocaml-piqilib")
(version "0.6.14")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/alavrik/piqi/archive/v"
- version ".tar.gz"))
- (sha256
- (base32
- "1ssccnwqzfyf7syfq2fv4zyhwayxwd75rhq9y28mvq1w6qbww4l7"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alavrik/piqi.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0lyqllmfsxmwlg7qidy92kvxi9n39lvachmydcyi81f8p07ykd2d"))))
(build-system ocaml-build-system)
(arguments
`(#:phases