summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:11:20 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:09 +0200
commit2209b362a5fe39cff5d0950938d7a913c8c08caf (patch)
treeca1a445fc8e08acb1b04297420060d04cac03eb9 /gnu/packages/ocaml.scm
parentf8b8e60e2cdd8465b604f5c272c5527bb5d709a9 (diff)
downloadpatches-2209b362a5fe39cff5d0950938d7a913c8c08caf.tar
patches-2209b362a5fe39cff5d0950938d7a913c8c08caf.tar.gz
gnu: ocaml4.02-ppx-deriving: Don't use unstable tarball.
* gnu/packages/ocaml.scm (ocaml4.02-ppx-deriving)[source]: Use GIT-FETCH and GIT-FILE-NAME. [arguments]: Add ‘make-git-checkout-writable’ phase. Fix indentation.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm31
1 files changed, 18 insertions, 13 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 4495e2902e..d7b2eeee87 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2948,13 +2948,14 @@ programs. It allows the definition of simple macros and file inclusion. Cpp oi
(name "ocaml4.02-ppx-deriving")
(version "4.1")
(source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/whitequark/ppx_deriving//archive/v"
- version ".tar.gz"))
- (sha256 (base32
- "1fr16g121j6zinwcprzlhx2py4271n9jzs2m9hq2f3qli2b1p0vl"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/whitequark/ppx_deriving.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0cy9p8d8cbcxvqyyv8fz2z9ypi121zrgaamdlp4ld9f3jnwz7my9"))))
(build-system ocaml-build-system)
(native-inputs
`(("js-build-tools" ,ocaml4.02-js-build-tools)
@@ -2969,13 +2970,17 @@ programs. It allows the definition of simple macros and file inclusion. Cpp oi
#:findlib ,ocaml4.02-findlib
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'make-git-checkout-writable
+ (lambda _
+ (for-each make-file-writable (find-files "."))
+ #t))
(delete 'configure)
- (add-before 'install 'fix-environment
- (lambda* (#:key outputs #:allow-other-keys)
- ;; the installation procedures looks for the installed module
- (setenv "OCAMLPATH"
- (string-append (getenv "OCAMLPATH") ":"
- (getenv "OCAMLFIND_DESTDIR"))))))))
+ (add-before 'install 'fix-environment
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; the installation procedures looks for the installed module
+ (setenv "OCAMLPATH"
+ (string-append (getenv "OCAMLPATH") ":"
+ (getenv "OCAMLFIND_DESTDIR"))))))))
(home-page "https://github.com/whitequark/ppx_deriving/")
(synopsis "Type-driven code generation for OCaml >=4.02")
(description "Ppx_deriving provides common infrastructure for generating