summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-04-26 22:37:24 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-04-26 23:34:41 +0200
commit09cd92a9831984e8efd6ca2829008be83e9c2bf5 (patch)
tree400900cb2af6062e164df65da6381faafd87fe92 /gnu/packages/ocaml.scm
parenteddfd11d7083912879603c4e0549e5fca04673e2 (diff)
downloadpatches-09cd92a9831984e8efd6ca2829008be83e9c2bf5.tar
patches-09cd92a9831984e8efd6ca2829008be83e9c2bf5.tar.gz
gnu: ocaml-zarith: Update to 1.7.
* gnu/packages/ocaml.scm (ocaml-zarith): Update to 1.7. [source]: Use git-fetch.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index b653bad866..f06b5c88f9 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1109,13 +1109,15 @@ files in these formats.")
(define-public ocaml-zarith
(package
(name "ocaml-zarith")
- (version "1.4.1")
+ (version "1.7")
(source (origin
- (method url-fetch)
- (uri (ocaml-forge-uri "zarith" version 1574))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml/Zarith")
+ (commit (string-append "release-" version))))
(sha256
(base32
- "0l36hzmfbvdai2kcgynh13vfdim5x2grnaw61fxqalyjm90c3di3"))))
+ "08x5xnamibhvxl50f1bb3jl9ym0hm6004hmc54xnrnrv7jxz9rvz"))))
(build-system ocaml-build-system)
(native-inputs
`(("perl" ,perl)))