summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-04-03 23:35:31 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-04-10 21:39:17 +0200
commitc4262cc932d0e1609923c401ad0a8d6160628372 (patch)
tree73f5c46584762ff8e4d1d22e1997c8aadd0817d3 /gnu/packages/ocaml.scm
parent718fadb8cabcc4c6fb2574017c2bc071289733b0 (diff)
downloadpatches-c4262cc932d0e1609923c401ad0a8d6160628372.tar
patches-c4262cc932d0e1609923c401ad0a8d6160628372.tar.gz
gnu: Add ocaml-mccs.
* gnu/packages/ocaml.scm (ocaml-mccs): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 263a318e58..04d5a84d1a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -363,6 +363,34 @@ Software distribution.")
;; With static-linking exception
(license license:lgpl2.1+)))
+(define-public ocaml-mccs
+ (package
+ (name "ocaml-mccs")
+ (version "1.1+9")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/AltGr/ocaml-mccs")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1i0hhkrqi7rqlainlg5pc4hibbx6b5dp3x99gmav8c3sbfvlk9mc"))))
+ (build-system dune-build-system)
+ (propagated-inputs `(("ocaml-cudf" ,ocaml-cudf)))
+ (home-page "http://www.i3s.unice.fr/~cpjm/misc/")
+ (synopsis "Upgrade path problem solver")
+ (description "Mccs (Multi Criteria CUDF Solver) is a CUDF problem solver.
+Mccs take as input a CUDF problem and computes the best solution according to
+a set of criteria. It relies on a Integer Programming solver or a
+Pseudo Boolean solver to achieve its task. Mccs can use a wide set of
+underlying solvers like Cplex, Gurobi, Lpsolver, Glpk, CbC, SCIP or WBO.")
+ (license (list
+ license:bsd-3
+ license:gpl3+
+ ;; With static-linking exception
+ license:lgpl2.1+))))
+
(define-public ocaml-opam-file-format
(package
(name "ocaml-opam-file-format")