summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:14:31 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:37 +0200
commit7848205b24ac2f700216c03707fea725bfb614d9 (patch)
treee86b070720cfcfa9bd1648e5115cda4c0f4128b1 /gnu/packages/ocaml.scm
parentfd2582bd7f2b92157f8639c36c88c2f3df0c7570 (diff)
downloadpatches-7848205b24ac2f700216c03707fea725bfb614d9.tar
patches-7848205b24ac2f700216c03707fea725bfb614d9.tar.gz
gnu: ocaml-utop: Don't use unstable tarball.
* gnu/packages/ocaml.scm (ocaml-utop)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a409b70049..789c828fd3 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4443,14 +4443,15 @@ instead of bindings to a C library.")
(package
(name "ocaml-utop")
(version "2.2.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/ocaml-community/utop/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1414snwmqaxs1x8wbpjf6fn3jsl01hq0phrr7639xmb5vh15mgd4"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml-community/utop.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "02hjkc0rdzfq3bqy9mqm5wmw312r3187v9cl66ynb6hxkj6s3glb"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"