summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:09:59 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:32:52 +0200
commit34f615a2c167660075d81c09621dd030122393b9 (patch)
tree5fc04e6dd4c3242e40bca9391ad465158610e06f /gnu/packages/ocaml.scm
parentd5dee1de7c8c330ccdcb2538f9d2a22ae5d64d6b (diff)
downloadpatches-34f615a2c167660075d81c09621dd030122393b9.tar
patches-34f615a2c167660075d81c09621dd030122393b9.tar.gz
gnu: ocaml-num: Don't use unstable tarball.
* gnu/packages/ocaml.scm (ocaml-num)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 9fcd0048fd..79c6a990c3 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -731,14 +731,15 @@ written in Objective Caml.")
(package
(name "ocaml-num")
(version "1.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/ocaml/num/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1xlkd0svc0mgq5s7nrm2rjrsvg15i9wxqkc1kvwjp6sv8vv8bb04"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml/num.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0a4mhxgs5hi81d227aygjx35696314swas0vzy3ig809jb7zq4h0"))))
(build-system ocaml-build-system)
(arguments
`(#:phases