summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:13:19 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:36 +0200
commit21b1845ddeb33624140711260029d166d1f20b07 (patch)
treee1e1b4e9dca3fd0df9fbff6e3a3cd407728d1f08 /gnu/packages/ocaml.scm
parent07c3711d0fdaae8cdd3e6a466b48b98add251918 (diff)
downloadpatches-21b1845ddeb33624140711260029d166d1f20b07.tar
patches-21b1845ddeb33624140711260029d166d1f20b07.tar.gz
gnu: ocaml4.02-ezjsonm: Don't use unstable tarball.
* gnu/packages/ocaml.scm (ocaml4.02-ezjsonm)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f341039461..3b44e7e9f2 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3945,14 +3945,15 @@ writing to these structures, and they are accessed via the Bigarray module.")
(package
(name "ocaml4.02-ezjsonm")
(version "0.4.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/mirage/ezjsonm/archive/"
- version ".tar.gz"))
- (sha256
- (base32
- "1kag0z2xlk4rw73a240dmkxh9rj6psxxcxkm7d7z0rrj6hzjajgq"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mirage/ezjsonm.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1y6p3ga6vj1wx5dyns7hjgd0qgrrn2hnn323a7y5didgci5pybls"))))
(build-system ocaml-build-system)
(native-inputs
`(("alcotest" ,ocaml4.02-alcotest)))