summaryrefslogtreecommitdiff
path: root/gnu/packages/ntp.scm
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2014-10-18 17:09:45 +0200
committerJohn Darrington <jmd@gnu.org>2014-10-19 10:03:34 +0200
commitd99e12d24750bff2bcf437906f281afdd844a72b (patch)
tree41e4216d166318436930c74d61ebcd8ddd35d316 /gnu/packages/ntp.scm
parent23459fa59b3e96baa07da1ae4c78af70c255ac20 (diff)
downloadpatches-d99e12d24750bff2bcf437906f281afdd844a72b.tar
patches-d99e12d24750bff2bcf437906f281afdd844a72b.tar.gz
gnu: Add ntp
* gnu/packages/ntp.scm: New file. * gnu-system.am (gnu/packages/ntp.scm): Add it.
Diffstat (limited to 'gnu/packages/ntp.scm')
-rw-r--r--gnu/packages/ntp.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
new file mode 100644
index 0000000000..75f8f900a3
--- /dev/null
+++ b/gnu/packages/ntp.scm
@@ -0,0 +1,49 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright 2014 John Darrington <jmd@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages ntp)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages which)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (srfi srfi-1))
+
+(define-public ntp
+ (package
+ (name "ntp")
+ (version "4.2.6p5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-"
+ (string-join (take (string-split version #\.) 2) ".")
+ "/ntp-" version ".tar.gz"))
+ (sha256
+ (base32
+ "077r69a41hasl8zf5c44km7cqgfhrkaj6a4jnr75j7nkz5qq7ayn"))))
+ (native-inputs `(("which" ,which)))
+ (build-system gnu-build-system)
+ (synopsis "Real time clock synchonization system")
+ (description "NTP is a system designed to synchronize the clocks of
+computers over a network.")
+ (license (x11-style
+ "http://www.eecis.udel.edu/~mills/ntp/html/copyright.html"
+ "A non-copyleft free licence from the University of Delaware"))
+ (home-page "http://www.ntp.org")))