summaryrefslogtreecommitdiff
path: root/gnu/packages/ntp.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-11-05 09:27:42 +0100
committerLudovic Courtès <ludo@gnu.org>2014-11-05 11:25:39 +0100
commit52b321e908467ac05f70ec7415aed8bd438f06db (patch)
tree30b5b88743f7f3d69a5197cfd1ca9a2c07096c78 /gnu/packages/ntp.scm
parent65fb4515f028b11d41cd5f07825c86df6efac1a5 (diff)
downloadpatches-52b321e908467ac05f70ec7415aed8bd438f06db.tar
patches-52b321e908467ac05f70ec7415aed8bd438f06db.tar.gz
gnu: ntp: Build with POSIX capabilities support on GNU/Linux.
* gnu/packages/ntp.scm (ntp)[inputs]: New field.
Diffstat (limited to 'gnu/packages/ntp.scm')
-rw-r--r--gnu/packages/ntp.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index 75f8f900a3..8e6ed4fd3c 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -19,6 +19,7 @@
(define-module (gnu packages ntp)
#:use-module (gnu packages)
#:use-module (gnu packages which)
+ #:use-module (gnu packages linux)
#:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (guix download)
@@ -39,11 +40,18 @@
(base32
"077r69a41hasl8zf5c44km7cqgfhrkaj6a4jnr75j7nkz5qq7ayn"))))
(native-inputs `(("which" ,which)))
+ (inputs
+ ;; Build with POSIX capabilities support on GNU/Linux. This allows 'ntpd'
+ ;; to run as non-root (when invoked with '-u'.)
+ (if (string-suffix? "-linux"
+ (or (%current-target-system) (%current-system)))
+ `(("libcap" ,libcap))
+ '()))
(build-system gnu-build-system)
(synopsis "Real time clock synchonization system")
(description "NTP is a system designed to synchronize the clocks of
computers over a network.")
- (license (x11-style
+ (license (x11-style
"http://www.eecis.udel.edu/~mills/ntp/html/copyright.html"
"A non-copyleft free licence from the University of Delaware"))
(home-page "http://www.ntp.org")))