summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-26 18:59:28 -0400
committerLeo Famulari <leo@famulari.name>2016-10-26 19:00:06 -0400
commit02c73adcdf0f29dbecd9a1bb3c9be3626cd5dea9 (patch)
treefb8fadc87f5b82dc35f44831af8b79eec37887b3 /gnu/packages/networking.scm
parenta19da40630138acea7169491a6926e00cf7d301b (diff)
parent5d73e3000030006b00e7e6644f3ced5d6176376e (diff)
downloadpatches-02c73adcdf0f29dbecd9a1bb3c9be3626cd5dea9.tar
patches-02c73adcdf0f29dbecd9a1bb3c9be3626cd5dea9.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index b79f4c2582..a348d07609 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -48,6 +48,7 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages libidn)
#:use-module (gnu packages linux)
#:use-module (gnu packages lua)
#:use-module (gnu packages mit-krb5)
@@ -424,6 +425,44 @@ and up to 1 Mbit/s downstream.")
;; src/md5.[ch] is released under the zlib license
(license (list license:isc license:zlib))))
+(define-public whois
+ (package
+ (name "whois")
+ (version "5.2.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://debian/pool/main/w/whois/"
+ name "_" version ".tar.xz"))
+ (sha256
+ (base32
+ "1wfdyqi64l5x56j259jrrlbh19b7q7i6r83a8q8rjzcqp0kl0vdj"))))
+ (build-system gnu-build-system)
+ ;; TODO: unbundle mkpasswd binary + its po files.
+ (arguments
+ `(#:tests? #f ; Does not exist
+ #:make-flags (list "CC=gcc"
+ (string-append "prefix=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; No configure
+ (add-before 'build 'setenv
+ (lambda _
+ (setenv "HAVE_ICONV" "1")
+ (setenv "HAVE_LIBIDN" "1"))))))
+ (inputs
+ `(("libidn" ,libidn)))
+ (native-inputs
+ `(("gettext" ,gnu-gettext)
+ ("perl" ,perl)))
+ (synopsis "Improved whois client")
+ (description "This whois client is intelligent and can
+automatically select the appropriate whois server for most queries.
+Because of historical reasons this also includes a tool called mkpasswd
+which can be used to encrypt a password with @code{crypt(3)}.")
+ (home-page "https://github.com/rfc1036/whois")
+ (license license:gpl2+)))
+
(define-public wireshark
(package
(name "wireshark")