summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-10 22:57:38 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-11 02:00:44 +0200
commit8faa9df7f36190fd6281eaea35e875f29ff6dfb1 (patch)
tree0a6b32084cd840e1ad6b2b665e1d9c9880504276 /gnu/packages/networking.scm
parent6e542e195d036b14909a1b39e295f2ac4a314b3d (diff)
downloadpatches-8faa9df7f36190fd6281eaea35e875f29ff6dfb1.tar
patches-8faa9df7f36190fd6281eaea35e875f29ff6dfb1.tar.gz
gnu: perl-net-dns: Update home page.
* gnu/packages/networking.scm (perl-net-dns)[home-page]: Use new (and HTTPS) URI. [source]: Add it to the list of download locations.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index a9696eb3c6..aa7059eb50 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -822,17 +822,19 @@ allows for heavy scripting.")
(source
(origin
(method url-fetch)
- (uri (string-append
- "mirror://cpan/authors/id/N/NL/NLNETLABS/Net-DNS-"
- version
- ".tar.gz"))
+ (uri
+ (list
+ (string-append "https://www.net-dns.org/download/Net-DNS-"
+ version ".tar.gz")
+ (string-append "mirror://cpan/authors/id/N/NL/NLNETLABS/Net-DNS-"
+ version ".tar.gz")))
(sha256
(base32
"1q62w9rf2w8kjzqagzr0rdn20ybl8gj3l6cdq4k8fw0sxa7zsycs"))))
(build-system perl-build-system)
(inputs
`(("perl-digest-hmac" ,perl-digest-hmac)))
- (home-page "http://search.cpan.org/dist/Net-DNS")
+ (home-page "https://www.net-dns.org/")
(synopsis
"Perl Interface to the Domain Name System")
(description "Net::DNS is the Perl Interface to the Domain Name System.")