summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-03 17:39:22 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-03 17:39:22 +0200
commitd27748674a49bc2251fce1d027378dc0ce24dc5c (patch)
tree6d74433f6c1a5293d7b5b74e7d2dd0cd89178de4 /gnu/packages/networking.scm
parent8ecdef3cbbf10ce93634eed3f759891afa7e7b6c (diff)
downloadpatches-d27748674a49bc2251fce1d027378dc0ce24dc5c.tar
patches-d27748674a49bc2251fce1d027378dc0ce24dc5c.tar.gz
gnu: hcxtools: Fix build failure.
* gnu/packages/networking.scm (hcxtools)[arguments]: Do not override C_INCLUDE_PATH.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm10
1 files changed, 1 insertions, 9 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index c492a7f2ad..13ece07740 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2442,15 +2442,7 @@ Ethernet and TAP interfaces is supported. Packet capture is also supported.")
#:tests? #f ; no test suite
#:phases
(modify-phases %standard-phases
- (delete 'configure)
- (add-after 'unpack 'set-environment
- (lambda* (#:key inputs #:allow-other-keys)
- (setenv "C_INCLUDE_PATH"
- (string-append (assoc-ref inputs "curl") "/include:"
- (assoc-ref inputs "libpcap") "/include:"
- (assoc-ref inputs "openssl") "/include:"
- (assoc-ref inputs "zlib") "/include"))
- #t)))))
+ (delete 'configure))))
(home-page "https://github.com/ZerBea/hcxtools")
(synopsis "Capture wlan traffic to hashcat and John the Ripper")
(description