summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-10-18 08:04:54 +0000
committerMarius Bakke <mbakke@fastmail.com>2016-10-24 17:40:53 +0100
commit9c798f9036d2d3f90e567052efb06b269c08ed14 (patch)
treecf6e81192e41faa03557820df8dd174546b4b143 /gnu/packages/networking.scm
parentbd1b1e0517b046a6ad6d48633d43c644edea7424 (diff)
downloadpatches-9c798f9036d2d3f90e567052efb06b269c08ed14.tar
patches-9c798f9036d2d3f90e567052efb06b269c08ed14.tar.gz
gnu: Add whois.
* gnu/packages/networking.scm (whois): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 52bd0c4cf6..ac8867352d 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -48,6 +48,7 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages libidn)
#:use-module (gnu packages linux)
#:use-module (gnu packages lua)
#:use-module (gnu packages mit-krb5)
@@ -424,6 +425,44 @@ and up to 1 Mbit/s downstream.")
;; src/md5.[ch] is released under the zlib license
(license (list license:isc license:zlib))))
+(define-public whois
+ (package
+ (name "whois")
+ (version "5.2.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://debian/pool/main/w/whois/"
+ name "_" version ".tar.xz"))
+ (sha256
+ (base32
+ "1wfdyqi64l5x56j259jrrlbh19b7q7i6r83a8q8rjzcqp0kl0vdj"))))
+ (build-system gnu-build-system)
+ ;; TODO: unbundle mkpasswd binary + its po files.
+ (arguments
+ `(#:tests? #f ; Does not exist
+ #:make-flags (list "CC=gcc"
+ (string-append "prefix=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; No configure
+ (add-before 'build 'setenv
+ (lambda _
+ (setenv "HAVE_ICONV" "1")
+ (setenv "HAVE_LIBIDN" "1"))))))
+ (inputs
+ `(("libidn" ,libidn)))
+ (native-inputs
+ `(("gettext" ,gnu-gettext)
+ ("perl" ,perl)))
+ (synopsis "Improved whois client")
+ (description "This whois client is intelligent and can
+automatically select the appropriate whois server for most queries.
+Because of historical reasons this also includes a tool called mkpasswd
+which can be used to encrypt a password with @code{crypt(3)}.")
+ (home-page "https://github.com/rfc1036/whois")
+ (license license:gpl2+)))
+
(define-public wireshark
(package
(name "wireshark")