aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-03-16 13:11:28 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-03-16 13:11:28 +0200
commit4cacd87e4d4b72945c19e993eef7af387fce957c (patch)
tree2f54fc1752941a849fa92c3f3a8bbb195e54b754 /gnu/packages/networking.scm
parent56f76b08be97549dcc409b090186103413dc4e4b (diff)
parent0f03c5316819385f3a4047ae50736b3db760f451 (diff)
downloadpatches-4cacd87e4d4b72945c19e993eef7af387fce957c.tar
patches-4cacd87e4d4b72945c19e993eef7af387fce957c.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 95253687cd..e36903b8af 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1141,3 +1141,28 @@ IPFIX, RSPAN, CLI, LACP, 802.1ag).")
"Command line interface for testing internet bandwidth using
speedtest.net.")
(license license:asl2.0)))
+
+(define-public tftp-hpa
+ (package
+ (name "tftp-hpa")
+ (version "5.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kernel.org/software/"
+ "network/tftp/tftp-hpa/tftp-hpa-" version
+ ".tar.xz"))
+ (sha256
+ (base32
+ "12vidchglhyc20znq5wdsbhi9mqg90jnl7qr9qs8hbvaz4fkdvmg"))))
+ (build-system gnu-build-system)
+ (arguments `(#:tests? #f)) ; no test target
+ (synopsis "HPA's tftp client")
+ (description
+ "This is a tftp client derived from OpenBSD tftp with some extra options
+added and bugs fixed. The source includes readline support but it is not
+enabled due to license conflicts between the BSD advertising clause and the GPL.")
+ (home-page "http://git.kernel.org/cgit/network/tftp/tftp-hpa.git/about/")
+ ;; Some source files are distributed under a 3-clause BSD license, and
+ ;; others under a 4-clause BSD license. Refer to the files in the source
+ ;; distribution for clarification.
+ (license (list license:bsd-3 license:bsd-4))))