summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-07-15 00:23:23 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2016-07-27 03:59:47 +0200
commit82ee141babe388071b8d2de2c5bebc950f702279 (patch)
tree3e9f345481df91e4e44a5fd42a3979a317be715b /gnu/packages/networking.scm
parent42ff54d5faeee9f92e1fdeb131cc4e1714953446 (diff)
downloadpatches-82ee141babe388071b8d2de2c5bebc950f702279.tar
patches-82ee141babe388071b8d2de2c5bebc950f702279.tar.gz
gnu: Add httping.
* gnu/packages/networking.scm (httping): New variable.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 14ae5c32b4..1ef401f245 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -31,11 +31,13 @@
#:use-module (guix build-system gnu)
#:use-module (gnu packages admin)
#:use-module (gnu packages adns)
+ #:use-module (gnu packages algebra)
#:use-module (gnu packages audio)
#:use-module (gnu packages bison)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages flex)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gtk)
#:use-module (gnu packages linux)
@@ -376,3 +378,37 @@ sniffer}, that lets you capture and interactively browse the contents of
network frames.")
(license license:gpl2+)
(home-page "https://www.wireshark.org/")))
+
+(define-public httping
+ (package
+ (name "httping")
+ (version "2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.vanheusden.com/httping/httping-"
+ version ".tgz"))
+ (sha256
+ (base32
+ "1110r3gpsj9xmybdw7w4zkhj3zmn5mnv2nq0ijbvrywbn019zdfs"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gettext" ,gnu-gettext)))
+ (inputs
+ `(("fftw" ,fftw)
+ ("ncurses" ,ncurses)
+ ("openssl" ,openssl)))
+ (arguments
+ `(#:make-flags (list "CC=gcc"
+ (string-append "DESTDIR=" (assoc-ref %outputs "out"))
+ "PREFIX=")
+ #:tests? #f)) ; no tests
+ (home-page "https://www.vanheusden.com/httping/")
+ (synopsis "Web server latency and throughput monitor")
+ (description
+ "httping measures how long it takes to connect to a web server, send an
+HTTP(S) request, and receive the reply headers. It is somewhat similar to
+@command{ping}, but can be used even in cases where ICMP traffic is blocked
+by firewalls or when you want to monitor the response time of the actual web
+application stack itself.")
+ (license license:gpl2))) ; with permission to link with OpenSSL