summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-08-18 23:56:18 -0400
committerMark H Weaver <mhw@netris.org>2015-08-18 23:56:18 -0400
commit2376963411a096aa0c8e77f27c4d1db1a9a7fa42 (patch)
tree9b23d686f9c4b2f6e405bcd4f486e4813274fe66 /gnu/packages/networking.scm
parente4fb9d2d974062b78d999562ba3aecc31aebcb96 (diff)
downloadpatches-2376963411a096aa0c8e77f27c4d1db1a9a7fa42.tar
patches-2376963411a096aa0c8e77f27c4d1db1a9a7fa42.tar.gz
Revert "PRELIMINARY: gnu: Add ppp."
This reverts commit ba139bd75bd783d2474e5f9ecc0dd6d3aac6a9c3.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm38
1 files changed, 0 insertions, 38 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index ac96b16d4e..dc139e28fe 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -23,7 +23,6 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
- #:use-module (gnu packages admin)
#:use-module (gnu packages tls))
(define-public miredo
@@ -147,40 +146,3 @@ receiving NDP messages.")
auto-negotiation and checksum offload on many network devices, especially
Ethernet devices.")
(license license:gpl2)))
-
-(define-public ppp
- (package
- (name "ppp")
- (version "2.4.7")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://download.samba.org/pub/" name "/"
- name "-" version ".tar.gz"))
- (sha256
- (base32
- "0c7vrjxl52pdwi4ckrvfjr08b31lfpgwf3pp0cqy76a77vfs7q02"))))
- (build-system gnu-build-system)
- (inputs
- `(("libpcap" ,libpcap)))
- (arguments
- `(#:tests? #f ; no test suite
- #:make-flags '("CC=gcc")
- #:phases (modify-phases %standard-phases
- (add-after
- 'unpack 'patch-pppd-makefile
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "pppd/Makefile.linux"
- (("/usr/include/crypt.h")
- (string-append (assoc-ref inputs "libc")
- "/include/crypt.h")))
- #t)))))
- (home-page "https://ppp.samba.org/")
- (synopsis "Point-to-Point Protocol (PPP)")
- (description
- "The Point-to-Point Protocol provides a standard way to transmit
-datagrams over a serial link, as well as a standard way for the machines at
-either end of the link to negotiate various optional characteristics of the
-link.")
- ;; XXX TODO Document all of the licenses.
- (license (license:non-copyleft
- "http://metadata.ftp-master.debian.org/changelogs//main/p/ppp/ppp_2.4.6-3.1_copyright"))))