summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2019-08-01 21:25:58 +0200
committerLudovic Courtès <ludo@gnu.org>2019-08-22 17:59:30 +0200
commita83e2a01fb5438c660166e12b0d7df5c470b9e4a (patch)
tree25ffe7fb23be1f2d48b8660f864607c2e8165b4a /gnu/packages/networking.scm
parent403b4e06854728ee857509053ef2b4c87024baea (diff)
downloadpatches-a83e2a01fb5438c660166e12b0d7df5c470b9e4a.tar
patches-a83e2a01fb5438c660166e12b0d7df5c470b9e4a.tar.gz
gnu: Add pixiewps.
* gnu/packages/networking.scm (pixiewps): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 4527c4927c..a8f98c54df 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -29,6 +29,7 @@
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2019 Timotej Lazar <timotej.lazar@araneo.si>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -946,6 +947,34 @@ attacking, testing, and cracking. All tools are command-line driven, which
allows for heavy scripting.")
(license (list license:gpl2+ license:bsd-3))))
+(define-public pixiewps
+ (package
+ (name "pixiewps")
+ (version "1.4.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/wiire-a/pixiewps/releases/"
+ "download/v" version "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "07nym6bqml0k9v29vnj003nrgnwrywgjvnljb7cdpsvnwilhbp64"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags
+ (list "CC=gcc"
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)) ; no configure script
+ #:tests? #f)) ; there are no tests
+ (home-page "https://github.com/wiire-a/pixiewps/")
+ (synopsis "Offline brute-force tool for Wi-Fi Protected Setup")
+ (description "Pixiewps implements the pixie-dust attack to brute
+force the Wi-Fi Protected Setup (WPS) PIN by exploiting the low or
+non-existing entropy of some access points.")
+ (license license:gpl3+)))
+
(define-public perl-danga-socket
(package
(name "perl-danga-socket")