summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-10-06 22:02:20 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-10-06 22:02:20 +0200
commite08902d3cbb307e1523485becbbdaf9aed56ac4a (patch)
treeca79454c4146f37c0e0f4d354d434816928812ed /gnu/packages/networking.scm
parent1714edc3d4e8d6da1b0cdef300ae882d0885f182 (diff)
parentf58702465d0b2daab1775d29439b73b4486a108a (diff)
downloadpatches-e08902d3cbb307e1523485becbbdaf9aed56ac4a.tar
patches-e08902d3cbb307e1523485becbbdaf9aed56ac4a.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm63
1 files changed, 61 insertions, 2 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 50afc2a547..753e73d9d1 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2019 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019 Timotej Lazar <timotej.lazar@araneo.si>
+;;; Copyright © 2019 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -592,14 +593,14 @@ of the same name.")
(define-public wireshark
(package
(name "wireshark")
- (version "3.0.3")
+ (version "3.0.5")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.wireshark.org/download/src/wireshark-"
version ".tar.xz"))
(sha256
- (base32 "0711jilp9sbgi46d105m3galw8n4wk5yncawi08031qxg2f754mg"))))
+ (base32 "087qv7nd7zlbckvcs37fkkg7v0mw0hjd5yfbghqym764fpjgqlf5"))))
(build-system cmake-build-system)
(arguments
`(#:phases
@@ -2581,3 +2582,61 @@ communication.")
(description "FRRouting (FRR) is an IP routing protocol suite which includes
protocol daemons for BGP, IS-IS, LDP, OSPF, PIM, and RIP. ")
(license license:gpl2+)))
+
+(define-public iwd
+ (package
+ (name "iwd")
+ (version "0.21")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.kernel.org/pub/scm/network/wireless/iwd.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "001dikinsa6kshwscjbvwipavzwpqnpvx9fpshcn63gbvbhyd393"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("dbus" ,dbus)
+ ("libtool" ,libtool)
+ ("ell" ,ell)
+ ("readline" ,readline)))
+ (native-inputs
+ `(("asciidoc" ,asciidoc)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkgconfig" ,pkg-config)
+ ("python" ,python)
+ ("openssl" ,openssl)))
+ (arguments
+ `(#:configure-flags
+ (let ((dbus (assoc-ref %outputs "out")))
+ (list "--disable-systemd-service"
+ "--enable-external-ell"
+ "--enable-hwsim"
+ "--enable-tools"
+ "--enable-wired"
+ "--enable-docs"
+ "--localstatedir=/var"
+ (string-append "--with-dbus-datadir=" dbus "/share/")
+ (string-append "--with-dbus-busdir="
+ dbus "/share/dbus-1/system-services")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'bootstrap 'pre-bootstrap
+ (lambda _
+ (substitute* "Makefile.am"
+ ;; Test disabled because it needs the kernel module
+ ;; 'pkcs8_key_parser' loaded.
+ (("unit\\/test-eapol.*? ") "")
+ ;; Don't try to 'mkdir /var'.
+ (("\\$\\(MKDIR_P\\) -m 700") "true"))
+ #t)))))
+ (home-page "https://git.kernel.org/pub/scm/network/wireless/iwd.git/")
+ (synopsis "Internet Wireless Daemon")
+ (description "iwd is a wireless daemon for Linux that aims to replace WPA
+Supplicant. It optimizes resource utilization by not depending on any external
+libraries and instead utilizing features provided by the Linux kernel to the
+maximum extent possible.")
+ (license license:lgpl2.1+)))