summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-01 13:19:06 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-01 13:19:06 +0100
commit7eaa37a19d3c0776fac415387ed5c1ed7d372b1d (patch)
treed5cebaaf5bd83068a443c449848f501b1451586a /gnu/packages/networking.scm
parentd2ea806436e25773221f8c9d6631db095b5f8969 (diff)
downloadpatches-7eaa37a19d3c0776fac415387ed5c1ed7d372b1d.tar
patches-7eaa37a19d3c0776fac415387ed5c1ed7d372b1d.tar.gz
gnu: sslh: Update to 1.19b.
* gnu/packages/networking.scm (sslh): Update to 1.19b. [inputs]: Add pcre. [home-page]: Update and use HTTPS.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 84428c3da9..ffdaf919fe 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1025,7 +1025,7 @@ library remains flexible, portable, and easily embeddable.")
(define-public sslh
(package
(name "sslh")
- (version "1.18")
+ (version "1.19b")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/yrutschle/sslh/archive/v"
@@ -1033,10 +1033,10 @@ library remains flexible, portable, and easily embeddable.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1vzw7a7s9lhspbn5zn3hw8hir4pkjgbd68yys4hfsnjp1h7bzjpn"))))
+ "0p0zfy5ifzj7508zqidgkf8g43frm7l5xcs5s6v7132lypcsbd4k"))))
(build-system gnu-build-system)
(native-inputs
- `(;; Tests dependencies.
+ `(;; Test dependencies.
("lcov" ,lcov)
("perl" ,perl)
("perl-io-socket-inet6" ,perl-io-socket-inet6)
@@ -1046,6 +1046,7 @@ library remains flexible, portable, and easily embeddable.")
(inputs
`(("libcap" ,libcap)
("libconfig" ,libconfig)
+ ("pcre" ,pcre)
("tcp-wrappers" ,tcp-wrappers)))
(arguments
'(#:phases
@@ -1075,7 +1076,7 @@ library remains flexible, portable, and easily embeddable.")
"USELIBWRAP=1"
(string-append "PREFIX=" (assoc-ref %outputs "out")))
#:test-target "test"))
- (home-page "http://www.rutschle.net/tech/sslh.shtml")
+ (home-page "https://www.rutschle.net/tech/sslh/README.html")
(synopsis "Applicative network protocol demultiplexer")
(description
"sslh is a network protocol demultiplexer. It acts like a switchboard,