summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-06-12 10:32:16 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-06-12 10:35:55 +0300
commitaf5faef90f810ca8508f210ec0dab152e812e610 (patch)
tree7ac24a6ddc18da7a1432dbd238733a0883b54b1a /gnu/packages/networking.scm
parentf37f949dfd3f148431d4f533a3d2297421db5185 (diff)
downloadpatches-af5faef90f810ca8508f210ec0dab152e812e610.tar
patches-af5faef90f810ca8508f210ec0dab152e812e610.tar.gz
gnu: aircrack-ng: Fix building on non-Intel machines.
* gnu/packages/networking.scm (aircrack-ng)[arguments]: Only use system optimizations on x86_64 and i686 machines.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 57a02e9f4a..d8fd1c80a0 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2016, 2017 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31,12 +32,12 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages networking)
- #:use-module (guix build-system perl)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
@@ -64,7 +65,8 @@
#:use-module (gnu packages python)
#:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
- #:use-module (gnu packages valgrind))
+ #:use-module (gnu packages valgrind)
+ #:use-module (ice-9 match))
(define-public macchanger
(package
@@ -634,7 +636,12 @@ live network and disk I/O bandwidth monitor.")
"libnl=true"
"pcre=true"
"experimental=true" ;build wesside-ng, etc.
- "AVX2FLAG=N" "AVX1FLAG=N" "SSEFLAG=Y"
+ "AVX2FLAG=N" "AVX1FLAG=N"
+ ,,@(match (%current-system)
+ ((or "x86_64-linux" "i686-linux")
+ `("SSEFLAG=Y"))
+ (_
+ `("NEWSSE=false")))
,(string-append "prefix=" %output))
#:phases (modify-phases %standard-phases
(delete 'configure) ;no configure phase