summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorGábor Boskovits <boskovits@gmail.com>2019-02-12 17:39:50 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-02-12 22:24:27 +0100
commitdbf87ecb5205828b93d58802881e48b88cbc0137 (patch)
tree7e53acebc06d734a4bdfe295939fea71f0be7795 /gnu/packages/networking.scm
parentea7cddaac782b2cdc789a354e172356ed5c183e7 (diff)
downloadpatches-dbf87ecb5205828b93d58802881e48b88cbc0137.tar
patches-dbf87ecb5205828b93d58802881e48b88cbc0137.tar.gz
gnu: Add frrouting.
* gnu/packages/networking.scm (frrouting): New variable.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm31
1 files changed, 30 insertions, 1 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index c71ae4a24d..afd83dcfdb 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -16,7 +16,7 @@
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
-;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
+;;; Copyright © 2017, 2019 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2018 Adam Van Ymeren <adam@vany.ca>
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
@@ -98,6 +98,7 @@
#:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
#:use-module (gnu packages valgrind)
+ #:use-module (gnu packages web)
#:use-module (gnu packages wm)
#:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xml)
@@ -2367,3 +2368,31 @@ communication over HTTP.")
be used to manage peer-to-peer network connections as needed for real time
communication.")
(license license:gpl3+)))
+
+(define-public frrouting
+ (package
+ (name "frrouting")
+ (version "6.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/FRRouting/frr/releases/"
+ "download/frr-" version "/frr-" version
+ ".tar.xz"))
+ (sha256
+ (base32
+ "0xfrvi62w8qlh46f504ka0skb7pm0g0p8vmdng4w90gsbirlzpdd"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("c-ares" ,c-ares)
+ ("json-c" ,json-c)
+ ("readline" ,readline)))
+ (native-inputs
+ `(("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-wrapper)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://frrouting.org/")
+ (synopsis "IP routing protocol suite")
+ (description "FRRouting (FRR) is an IP routing protocol suite which includes
+protocol daemons for BGP, IS-IS, LDP, OSPF, PIM, and RIP. ")
+ (license license:gpl2+)))