summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-07-28 23:38:18 +0200
committerLeo Famulari <leo@famulari.name>2016-08-08 22:36:36 -0400
commit68b14f2e157dc3fd78b3b91a95d0491020462d35 (patch)
treedde95b196f17ccff7a834325bf8437a6245bc738 /gnu/packages/networking.scm
parent6b5e654dd46e255ee4c51d5363b94e06757ed752 (diff)
downloadpatches-68b14f2e157dc3fd78b3b91a95d0491020462d35.tar
patches-68b14f2e157dc3fd78b3b91a95d0491020462d35.tar.gz
gnu: Add perl-net-dns.
* gnu/packages/networking.scm (perl-net-dns): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 5135fb07f7..e146f8b902 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -24,6 +24,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages networking)
+ #:use-module (guix build-system perl)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
@@ -412,3 +413,26 @@ HTTP(S) request, and receive the reply headers. It is somewhat similar to
by firewalls or when you want to monitor the response time of the actual web
application stack itself.")
(license license:gpl2))) ; with permission to link with OpenSSL
+
+(define-public perl-net-dns
+ (package
+ (name "perl-net-dns")
+ (version "1.06")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/N/NL/NLNETLABS/Net-DNS-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "07m5331132h9xkh1i6jv9d80f571yva27iqa31aq4sm31iw7nn53"))))
+ (build-system perl-build-system)
+ (inputs
+ `(("perl-digest-hmac" ,perl-digest-hmac)))
+ (home-page "http://search.cpan.org/dist/Net-DNS")
+ (synopsis
+ "Perl Interface to the Domain Name System")
+ (description "Net::DNS is the Perl Interface to the Domain Name System.")
+ (license license:x11)))