summaryrefslogtreecommitdiff
path: root/gnu/packages/ncurses.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-02-14 16:00:38 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-15 22:02:56 +0100
commit717c433c46e8e9fc77b796e485092e2cccee336a (patch)
treec7233da1bde53282d7949f4c680b88f800f25778 /gnu/packages/ncurses.scm
parent62852fa27c8c9825023c3db0afacc532621cb6d1 (diff)
downloadpatches-717c433c46e8e9fc77b796e485092e2cccee336a.tar
patches-717c433c46e8e9fc77b796e485092e2cccee336a.tar.gz
gnu: ncurses: Update to 6.2.
* gnu/packages/ncurses.scm (ncurses): Update to 6.2. [arguments]: Remove phase "apply-rollup-patch". [native-inputs]: Remove "rollup-patch" input.
Diffstat (limited to 'gnu/packages/ncurses.scm')
-rw-r--r--gnu/packages/ncurses.scm18
1 files changed, 2 insertions, 16 deletions
diff --git a/gnu/packages/ncurses.scm b/gnu/packages/ncurses.scm
index 75ad492822..12e16b2403 100644
--- a/gnu/packages/ncurses.scm
+++ b/gnu/packages/ncurses.scm
@@ -40,7 +40,7 @@
(define-public ncurses
(package
(name "ncurses")
- (version "6.1-20190609")
+ (version "6.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/ncurses/ncurses-"
@@ -48,7 +48,7 @@
".tar.gz"))
(sha256
(base32
- "05qdmbmrrn88ii9f66rkcmcyzp1kb1ymkx7g040lfkd1nkp7w1da"))))
+ "17bcm2z1rdx5gmzj5fb8cp7f28aw5b4g2z4qvvqg3yg0fq66wc1h"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;1 MiB of man pages
@@ -188,8 +188,6 @@
,@(if (target-mingw?) '("--enable-term-driver") '()))))
#:tests? #f ; no "check" target
#:phases (modify-phases %standard-phases
- (add-after 'unpack 'apply-rollup-patch
- ,apply-rollup-patch-phase)
(replace 'configure ,configure-phase)
(add-after 'install 'post-install
,post-install-phase)
@@ -201,18 +199,6 @@
`(,@(if (%current-target-system)
`(("self" ,this-package)) ;for `tic'
'())
-
- ("rollup-patch"
- ,(origin
- (method url-fetch)
- (uri (string-append
- "https://invisible-mirror.net/archives/ncurses/"
- (car (string-split version #\-))
- "/ncurses-" version "-patch.sh.bz2"))
- (sha256
- (base32
- "0hqlqdqmh7lfs6dwj763qksb4j9nk0pv6crzx5gnp6n4caz3i46g"))))
-
("pkg-config" ,pkg-config)))
(native-search-paths
(list (search-path-specification