summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-14 13:13:40 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-14 13:13:40 +0100
commit961d2ee2695b38503b463d055e9c7edbcc0bf307 (patch)
tree82d9b40477a1d4d88e75a187b2b637a56751480b /gnu/packages/music.scm
parent7cf79d7a51ff5dde4fc430fab2296b5f7de08953 (diff)
parentaebba13c0bef5a58697f1a9fe8337967cc01300f (diff)
downloadpatches-961d2ee2695b38503b463d055e9c7edbcc0bf307.tar
patches-961d2ee2695b38503b463d055e9c7edbcc0bf307.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm42
1 files changed, 3 insertions, 39 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index fa70e9d1ce..d0ea08fe6b 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -864,7 +864,7 @@ interface. It is implemented as a frontend to @code{klick}.")
(define-public libgme
(package
(name "libgme")
- (version "0.6.2")
+ (version "0.6.3")
(source (origin
(method url-fetch)
(uri (string-append "https://bitbucket.org/mpyne/game-music-emu/"
@@ -872,10 +872,10 @@ interface. It is implemented as a frontend to @code{klick}.")
".tar.xz"))
(sha256
(base32
- "0hkkmxbaas2sirlb5i4r10mgbbiaapjx8pazifabwba23m3wnijh"))))
+ "07857vdkak306d9s5g6fhmjyxk7vijzjhkmqb15s7ihfxx9lx8xb"))))
(build-system cmake-build-system)
(arguments
- '(#:tests? #f)) ; no check target
+ '(#:tests? #f)) ; no check target
(home-page "https://bitbucket.org/mpyne/game-music-emu")
(synopsis "Video game music file playback library")
(description
@@ -4615,42 +4615,6 @@ discard bad quality ones.
@end itemize\n")
(license license:expat))))
-(define-public lpd8editor
- (package
- (name "lpd8editor")
- (version "0.0.13")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/charlesfleche/lpd8editor.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0lsz3v493ilq2zr016m7kvymrplxd0n3pqv1pjglpq1h7sjw9764"))))
- (build-system gnu-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'setenv
- (lambda _
- (setenv "INSTALL_PREFIX"
- (assoc-ref %outputs "out"))))
- (delete 'configure) ; no configure script
- (add-before 'build 'qmake
- (lambda _ (invoke "qmake"))))))
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (inputs
- `(("alsa" ,alsa-lib)
- ("qtbase" ,qtbase)
- ("qtsvg" ,qtsvg)))
- (synopsis "Graphical editor for the Akai LPD8 MIDI controller")
- (description "lpd8editor is a graphical patch editor for the Akai LPD8 MIDI
-controller.")
- (home-page "https://github.com/charlesfleche/lpd8editor")
- (license license:expat)))
-
(define-public fmit
(package
(name "fmit")