summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-06-18 17:37:47 +0200
committerRicardo Wurmus <rekado@elephly.net>2015-06-23 21:41:42 +0200
commitec8da0e25d6656fc81207e43a3dc699e88ef8d95 (patch)
treeb45b18ce315a8878aa22fa97a5448cf0f52ef7d8 /gnu/packages/music.scm
parent9e8505343ee02dadf51ec53d1138b984f75253a5 (diff)
downloadpatches-ec8da0e25d6656fc81207e43a3dc699e88ef8d95.tar
patches-ec8da0e25d6656fc81207e43a3dc699e88ef8d95.tar.gz
gnu: Add setBfree.
* gnu/packages/audio.scm (setbfree): New variable.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a42d5c35c5..9cf9772086 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -38,6 +38,7 @@
#:use-module (gnu packages gcc)
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
+ #:use-module (gnu packages gl)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
@@ -322,6 +323,51 @@ your own lessons.")
Editor. It is compatible with Power Tab Editor 1.7 and Guitar Pro.")
(license license:gpl3+)))
+(define-public setbfree
+ (package
+ (name "setbfree")
+ (version "0.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://github.com/pantherb/setBfree/releases/download/v"
+ version "/setbfree-" version ".tar.gz"))
+ (sha256
+ (base32
+ "045bgp7qsigpbrhk7qvgvliwiy26sajifwn7f2jvk90ckfqnlw4b"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no "check" target
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "FONTFILE="
+ (assoc-ref %build-inputs "font-bitstream-vera")
+ "/share/fonts/truetype/VeraBd.ttf"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-CC-variable
+ (lambda _ (setenv "CC" "gcc") #t))
+ (delete 'configure))))
+ (inputs
+ `(("jack" ,jack-1)
+ ("lv2" ,lv2)
+ ("zita-convolver" ,zita-convolver)
+ ("glu" ,glu)
+ ("ftgl" ,ftgl)
+ ("font-bitstream-vera" ,font-bitstream-vera)))
+ (native-inputs
+ `(("help2man" ,help2man)
+ ("pkg-config" ,pkg-config)))
+ (home-page "http://setbfree.org")
+ (synopsis "Tonewheel organ")
+ (description
+ "setBfree is a MIDI-controlled, software synthesizer designed to imitate
+the sound and properties of the electromechanical organs and sound
+modification devices that brought world-wide fame to the names and products of
+Laurens Hammond and Don Leslie.")
+ (license license:gpl2+)))
+
(define-public tuxguitar
(package
(name "tuxguitar")