summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-04-10 17:42:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-04-10 18:22:51 +0200
commitad67ca3d411349aa2f968f34c069baad94f9a364 (patch)
tree81c601992abcf0497f3d953ea8ba4866261f3dd5 /gnu/packages/music.scm
parent4396e9b54a0a6da977d3816c1e5ebed9a3f5f40f (diff)
downloadpatches-ad67ca3d411349aa2f968f34c069baad94f9a364.tar
patches-ad67ca3d411349aa2f968f34c069baad94f9a364.tar.gz
gnu: Fix build for packages inheriting from gx-guvnor-lv2.
This is a follow-up to commit 35f909d45c21739ac6f69dae6b98fec8a10b4c5b. * gnu/packages/music.scm (gx-vbass-preamp-lv2)[arguments]: Make "install" target independent from "all". (gx-overdriver-lv2, gx-tone-mender-lv2, gx-push-pull-lv2, gx-saturator-lv2, gx-switchless-wah-lv2, gx-slow-gear-lv2): Inherit from "gx-vbass-preamp-lv2".
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm22
1 files changed, 16 insertions, 6 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index b1e8dd7865..c384f8bc73 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2356,6 +2356,16 @@ simulation of an overdrive or distortion pedal for guitars.")
(base32
"1dzksdfrva666gpi62fd2ni9rhf18sl917f1894qr0b17pbdh9k1"))
(file-name (string-append name "-" version "-checkout"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments gx-guvnor-lv2)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (replace 'configure
+ (lambda _
+ (substitute* "Makefile"
+ (("INSTALL_DIR = .*") "INSTALL_DIR=/lib/lv2\n")
+ (("install : all") "install :"))
+ #t))))))
(home-page "https://github.com/brummer10/GxVBassPreAmp.lv2")
(synopsis "Simulation of the Vox Venue Bass 100 Pre Amp Section")
(description "This package provides the LV2 plugin \"GxVBassPreAmp\", a
@@ -2365,7 +2375,7 @@ Section."))))
(define-public gx-overdriver-lv2
(let ((commit "ed71801987449414bf3adaa0dbfac68e8775f1ce")
(revision "1"))
- (package (inherit gx-guvnor-lv2)
+ (package (inherit gx-vbass-preamp-lv2)
(name "gx-overdriver-lv2")
(version (string-append "0-" revision "." (string-take commit 9)))
(source (origin
@@ -2385,7 +2395,7 @@ overdrive effect."))))
(define-public gx-tone-mender-lv2
(let ((commit "b6780b4a3e4782b3ed0e5882d6788f178aed138f")
(revision "1"))
- (package (inherit gx-guvnor-lv2)
+ (package (inherit gx-vbass-preamp-lv2)
(name "gx-tone-mender-lv2")
(version (string-append "0-" revision "." (string-take commit 9)))
(source (origin
@@ -2405,7 +2415,7 @@ clean boost effect with a 3-knob tonestack."))))
(define-public gx-push-pull-lv2
(let ((commit "7f76ae2068498643ac8671ee0930b13ee3fd8eb5")
(revision "1"))
- (package (inherit gx-guvnor-lv2)
+ (package (inherit gx-vbass-preamp-lv2)
(name "gx-push-pull-lv2")
(version (string-append "0-" revision "." (string-take commit 9)))
(source (origin
@@ -2444,7 +2454,7 @@ pedal.")))
(define-public gx-saturator-lv2
(let ((commit "0b581ac85c515325b9f16e51937cae6e1bf81a0a")
(revision "2"))
- (package (inherit gx-guvnor-lv2)
+ (package (inherit gx-vbass-preamp-lv2)
(name "gx-saturator-lv2")
(version (string-append "0-" revision "." (string-take commit 9)))
(source (origin
@@ -2546,7 +2556,7 @@ adjusts the amount of harmonics."))))
(define-public gx-slow-gear-lv2
(let ((commit "cb852e0426f4e6fe077e7f1ede73a4da335cfc5e")
(revision "2"))
- (package (inherit gx-guvnor-lv2)
+ (package (inherit gx-vbass-preamp-lv2)
(name "gx-slow-gear-lv2")
(version (string-append "0-" revision "." (string-take commit 9)))
(source (origin
@@ -2566,7 +2576,7 @@ slow gear audio effect to produce volume swells."))))
(define-public gx-switchless-wah-lv2
(let ((commit "7b08691203314612999f0ce2328cdc1161cd6665")
(revision "2"))
- (package (inherit gx-guvnor-lv2)
+ (package (inherit gx-vbass-preamp-lv2)
(name "gx-switchless-wah-lv2")
(version (string-append "0-" revision "." (string-take commit 9)))
(source (origin