summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-06-18 13:45:19 -0400
committerKei Kebreau <kkebreau@posteo.net>2018-06-18 13:46:46 -0400
commit3fe43df716fb23da75e5ca6f8d817fbe01b0087d (patch)
tree0b54ef8a1215cadc4ffbc23bae3fa5db278b16e5 /gnu/packages/music.scm
parenta181e858c7ece2bee3ec9fe49956b74ce508a25b (diff)
downloadpatches-3fe43df716fb23da75e5ca6f8d817fbe01b0087d.tar
patches-3fe43df716fb23da75e5ca6f8d817fbe01b0087d.tar.gz
gnu: schismtracker: Update to 20180523.
* gnu/packages/music.scm (schismtracker): Update to 20180523. [arguments]: Use 'invoke' in the 'autoconf' phase.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index f06885d69e..daefbc57fa 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2683,7 +2683,7 @@ for improved Amiga ProTracker 2/3 compatibility.")
(define-public schismtracker
(package
(name "schismtracker")
- (version "20170910")
+ (version "20180513")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2692,7 +2692,7 @@ for improved Amiga ProTracker 2/3 compatibility.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "01gfcjngbpv87y9w5jln8k313hycpkb1d617hdy2cdw2hxqzlclz"))
+ "1yjfd02arb51n0vyv11qgpn6imh7hcqnc3953cbvgwb4cnrswk9f"))
(modules '((guix build utils)))
(snippet
;; Remove use of __DATE__ and __TIME__ for reproducibility.
@@ -2706,7 +2706,7 @@ for improved Amiga ProTracker 2/3 compatibility.")
`(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'autoconf
- (lambda _ (zero? (system* "autoreconf" "-vfi"))))
+ (lambda _ (invoke "autoreconf" "-vfi")))
(add-before 'configure 'link-libm
(lambda _ (setenv "LIBS" "-lm") #t)))))
(native-inputs