summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2018-05-27 15:58:30 +0100
committerEfraim Flashner <efraim@flashner.co.il>2018-05-27 22:33:05 +0300
commit1222a64c02582baf852abd1822342697ff6d1c60 (patch)
treec7f4d3fc9aeada254ec81164f8860396afe7cbac /gnu/packages/music.scm
parent01c4869003884fc28b8993077474399b67d7be1c (diff)
downloadpatches-1222a64c02582baf852abd1822342697ff6d1c60.tar
patches-1222a64c02582baf852abd1822342697ff6d1c60.tar.gz
gnu: libechonest: Remove package.
It appears the "EchoNest" service isn't available anymore which makes this package obsolete. * gnu/packages/music.scm (libechonest): Remove variable. (clementine)[inputs]: Remove libechonest. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index cc7926f85c..8f68a29db9 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -262,7 +262,6 @@ score, keyboard, guitar, drum and controller views.")
("gst-plugins-base" ,gst-plugins-base)
("libcdio" ,libcdio)
("libmygpo-qt" ,libmygpo-qt)
- ("libechonest" ,libechonest)
;; TODO: Package libgpod.
("libmtp" ,libmtp)
("libxml2" ,libxml2)
@@ -3809,33 +3808,6 @@ OSC connections.")
the electronic or dubstep genre.")
(license license:gpl3+)))
-(define-public libechonest
- (package
- (name "libechonest")
- (version "2.3.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "git://anongit.kde.org/libechonest.git")
- (commit version)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "0xbavf9f355dl1d3qv59x4ryypqrdanh9xdvw2d0q66l008crdkq"))))
- (build-system cmake-build-system)
- (arguments
- '(#:tests? #f ; Tests require Internet access
- #:configure-flags '("-DBUILD_WITH_QT4=OFF")))
- (inputs
- `(("qtbase" ,qtbase)
- ("qjson" ,qjson)))
- (home-page "https://projects.kde.org/projects/playground/libs/libechonest")
- (synopsis "C++/Qt classes to interface with The Echo Nest API")
- (description "@code{libechonest} is a collection of C++/Qt classes
-designed to make a developer's life easy when trying to use the APIs provided
-by The Echo Nest.")
- (license license:gpl2+)))
-
(define-public libmygpo-qt
(package
(name "libmygpo-qt")