summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-10-22 11:26:20 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-24 07:54:43 +0200
commit306556528e4f1143cd12969f9805067cfdd8f5da (patch)
tree734ce6a03916b1907189725aa2ad44365d559f9f /gnu/packages/music.scm
parent2809a355b6473d947db24a0d80b4d2e8c454d9d7 (diff)
downloadpatches-306556528e4f1143cd12969f9805067cfdd8f5da.tar
patches-306556528e4f1143cd12969f9805067cfdd8f5da.tar.gz
gnu: Add sorcer.
* gnu/packages/music.scm (sorcer): New variable.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index ea1904596e..6aca39cedd 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3296,3 +3296,41 @@ based around a MIDI sequencer that features a rich understanding of music
notation and includes basic support for digital audio.")
(home-page "http://www.rosegardenmusic.com/")
(license license:gpl2)))
+
+(define-public sorcer
+ (package
+ (name "sorcer")
+ (version "1.1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/openAVproductions/"
+ "openAV-Sorcer/archive/release-"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "07iyqj28wm0xc4arrq893bm12xjpz65db7ynrlmf6w8krg8wjmd0"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; no tests included
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'build-faust-sources
+ (lambda* (#:key inputs #:allow-other-keys)
+ (with-directory-excursion "faust"
+ (delete-file "main.cpp")
+ (zero? (system* "faust" "-i"
+ "-a" "lv2synth.cpp"
+ "-o" "main.cpp" "main.dsp"))))))))
+ (inputs
+ `(("boost" ,boost)
+ ("lv2" ,lv2)
+ ("ntk" ,ntk)))
+ (native-inputs
+ `(("faust" ,faust)
+ ("pkg-config" ,pkg-config)))
+ (home-page "http://openavproductions.com/sorcer/")
+ (synopsis "Wavetable LV2 plugin synth")
+ (description "Sorcer is a wavetable LV2 plugin synthesizer, targeted at
+the electronic or dubstep genre.")
+ (license license:gpl3+)))