summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2019-02-27 01:10:48 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2019-02-27 01:10:48 +0100
commit8d611ef0850da62db2f3fbd6ff23b1e16f986136 (patch)
tree4697c1a2a71abc6ed106a1b652b6568eee4a7eaf /gnu/packages/music.scm
parent2dad4c910ab9b0ca1cb86592e101b5c6d50ce3f1 (diff)
downloadpatches-8d611ef0850da62db2f3fbd6ff23b1e16f986136.tar
patches-8d611ef0850da62db2f3fbd6ff23b1e16f986136.tar.gz
gnu: musescore: Update to 3.0.3.
* gnu/packages/music.scm (musescore): Update to 3.0.3. [source]: Remove now obsolete patch. [arguments]: Do not use bundled (as a submodule) libcrashreporter-qt. * gnu/packages/patches/musescore-fix-use_webengine.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Apply file removal.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 2f0fb4cde9..98ed92a749 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3637,7 +3637,7 @@ audio samples and various soft sythesizers. It can receive input from a MIDI ke
(define-public musescore
(package
(name "musescore")
- (version "3.0.2")
+ (version "3.0.3")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3646,7 +3646,7 @@ audio samples and various soft sythesizers. It can receive input from a MIDI ke
(file-name (git-file-name name version))
(sha256
(base32
- "1w9il6gg0dh4yi20nbdcibx5z5z4bvzppq8wsqf1l916hnczsj3s"))
+ "1drgmivqs2c5xck7dy5y9xf41wfnnj7n84069h273q96b783cx3f"))
(modules '((guix build utils)))
(snippet
;; Un-bundle OpenSSL and remove unused libraries.
@@ -3660,17 +3660,14 @@ audio samples and various soft sythesizers. It can receive input from a MIDI ke
'("thirdparty/freetype"
"thirdparty/openssl"
"thirdparty/portmidi"))
- #t))
- ;; Fix compilation error due to BUILD_WEBENGINE CMake option not
- ;; properly handled. Applied upstream already:
- ;; <https://github.com/musescore/MuseScore/commit/bb0c1a9b4940f3f6b52c0df535289ec8a3bc9e03>
- (patches (search-patches "musescore-fix-use_webengine.patch"))))
+ #t))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags
- `("-DUSE_SYSTEM_FREETYPE=ON"
+ `("-DBUILD_CRASH_REPORTER=OFF"
"-DBUILD_WEBENGINE=OFF"
- "-DDOWNLOAD_SOUNDFONT=OFF")
+ "-DDOWNLOAD_SOUNDFONT=OFF"
+ "-DUSE_SYSTEM_FREETYPE=ON")
;; There are tests, but no simple target to run. The command used to
;; run them is:
;;