summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2019-11-08 09:25:08 +0000
committerLudovic Courtès <ludo@gnu.org>2019-11-27 00:03:03 +0100
commit7281c8fd7eed3bfbf2c7ed9879bcb89603eac225 (patch)
treece536a3a707bfd375bafa016af5f4f708245a84a /gnu/packages/music.scm
parent778ae9f980c74d6b093eaae68ca5ee2be5f2ca8a (diff)
downloadpatches-7281c8fd7eed3bfbf2c7ed9879bcb89603eac225.tar
patches-7281c8fd7eed3bfbf2c7ed9879bcb89603eac225.tar.gz
gnu: Add helm.
* gnu/packages/music.scm: (helm): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm59
1 files changed, 59 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index ab91d8e36f..3d9b5a14fd 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5047,3 +5047,62 @@ Soul Force), MVerb, Nekobi, and ProM.")
MacArthur's AVLdrums. This plugin provides a convenient way to sequence and mix
MIDI drums and comes as two separate drumkits: Black Pearl and Red Zeppelin.")
(license license:gpl2+)))
+
+(define-public helm
+ (package
+ (name "helm")
+ (version "0.9.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/mtytel/helm.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17ys2vvhncx9i3ydg3xwgz1d3gqv4yr5mqi7vr0i0ca6nad6x3d4"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no "check" target
+ #:make-flags
+ (list (string-append "DESTDIR=" (assoc-ref %outputs "out"))
+ "lv2" "standalone")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'include-pnglib-code-and-remove-usr-from-paths
+ (lambda _
+ (substitute* "standalone/builds/linux/Makefile"
+ (("JUCE_INCLUDE_PNGLIB_CODE=0")
+ "JUCE_INCLUDE_PNGLIB_CODE=1"))
+ (substitute* "builds/linux/LV2/Makefile"
+ (("JUCE_INCLUDE_PNGLIB_CODE=0")
+ "JUCE_INCLUDE_PNGLIB_CODE=1"))
+ (substitute* "Makefile"
+ (("/usr") ""))
+ #t))
+ (add-before 'reset-gzip-timestamps 'make-gz-files-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ (for-each make-file-writable
+ (find-files (string-append (assoc-ref outputs "out"))
+ ".*\\.gz$"))
+ #t))
+ (delete 'configure))))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("curl" ,curl)
+ ("freetype2" ,freetype)
+ ("hicolor-icon-theme" ,hicolor-icon-theme)
+ ("libxcursor" ,libxcursor)
+ ("libxinerama", libxinerama)
+ ("jack", jack-1)
+ ("mesa" ,mesa)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("lv2", lv2)))
+ (home-page "https://tytel.org/helm/")
+ (synopsis "Polyphonic synth with lots of modulation")
+ (description "Helm is a cross-platform polyphonic synthesizer available standalone
+and as an LV2 plugin.")
+ (license license:gpl3+)))