aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/mp3.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-04-16 18:15:28 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-04-16 18:15:28 +0200
commit5d904d63f4d43e3f0e4be38c5f5404e029c00a22 (patch)
treeb2893eceae99c967e0f49cdbfe084f6c7d4767c4 /gnu/packages/mp3.scm
parentbab5f3a7f62150ae009e78d03c4b1f5b1646104c (diff)
parentd0ee11b2f000c3c027fd8370bc2195266398444f (diff)
downloadpatches-5d904d63f4d43e3f0e4be38c5f5404e029c00a22.tar
patches-5d904d63f4d43e3f0e4be38c5f5404e029c00a22.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/mp3.scm')
-rw-r--r--gnu/packages/mp3.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index 6dc58e2cc8..49313123c5 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -468,21 +468,21 @@ compression format (.mpc files).")
(define-public eyed3
(package
(name "eyed3")
- (version "0.8")
+ (version "0.8.5")
(source (origin
(method url-fetch)
- (uri (string-append
- "http://eyed3.nicfit.net/releases/eyeD3-"
- version ".tar.gz"))
+ (uri (pypi-uri "eyeD3" version))
(sha256
(base32
- "1dcswb0f6w3b05s1v43pq8fmavkd5g88ysndn9160wlaa1v9n40h"))))
+ "0rkx859z82wqnfb0dzpa1647cq43aqb39ri9rd5r3jz597qr9zdd"))))
(build-system python-build-system)
(arguments
`(#:tests? #f)) ; the required test data contains copyrighted material.
(propagated-inputs
- `(("python-six" ,python-six)
- ("python-grako" ,python-grako)))
+ `(("python-grako" ,python-grako)
+ ("python-magic" ,python-magic)
+ ("python-pathlib" ,python-pathlib)
+ ("python-six" ,python-six)))
(synopsis "MP3 tag ID3 metadata editor")
(description "eyeD3 is a Python tool for working with audio files,
specifically mp3 files containing ID3 metadata (i.e. song info). It provides a
@@ -508,12 +508,13 @@ command-line tool.")
(arguments
`(#:tests? #f ; tests require googletest *sources*
;;#:configure-flags '("-DBUILD_TESTS=ON") ; for building the tests
+ #:configure-flags '("-DBUILD_TOOLS=ON") ; for fpcalc
#:test-target "check"))
(inputs
;; requires one of FFmpeg (prefered), FFTW3 or vDSP
;; use the same ffmpeg version as for acoustid-fingerprinter
`(("ffmpeg" ,ffmpeg)
- ("boots" ,boost)))
+ ("boost" ,boost)))
(home-page "https://acoustid.org/chromaprint")
(synopsis "Audio fingerprinting library")
(description "Chromaprint is a library for calculating audio