summaryrefslogtreecommitdiff
path: root/gnu/packages/mit-krb5.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2013-11-04 13:33:49 -0500
committerMark H Weaver <mhw@netris.org>2013-11-04 13:38:06 -0500
commit7a78cc7af24a1303dd0117cb977e15ca89a5dad8 (patch)
treeda22901df6422742da8e3d58e2eb724a4c7135ff /gnu/packages/mit-krb5.scm
parent2ebab8e909b377d58bb52c33d3a31d121a0f64de (diff)
downloadpatches-7a78cc7af24a1303dd0117cb977e15ca89a5dad8.tar
patches-7a78cc7af24a1303dd0117cb977e15ca89a5dad8.tar.gz
gnu: mit-krb5: don't assume arguments are evaluated right-to-left.
* gnu/packages/patches/mit-krb5-init-fix.patch: New file. * gnu/packages/mit-krb5.scm (mit-krb5): Apply patch at the end of the custom unpack phase. * gnu-system.am (dist_patch_DATA): Add patch.
Diffstat (limited to 'gnu/packages/mit-krb5.scm')
-rw-r--r--gnu/packages/mit-krb5.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/mit-krb5.scm b/gnu/packages/mit-krb5.scm
index 8222212d95..361cd36f25 100644
--- a/gnu/packages/mit-krb5.scm
+++ b/gnu/packages/mit-krb5.scm
@@ -37,6 +37,8 @@
(sha256 (base32
"1daiaxgkxcryqs37w28v4x1vajqmay4l144d1zd9c2d7jjxr9gcs"))))
(build-system gnu-build-system)
+ (native-inputs
+ `(("patch/init-fix" ,(search-patch "mit-krb5-init-fix.patch"))))
(inputs `(("bison" ,bison)
("perl" ,perl)))
(arguments
@@ -51,7 +53,12 @@
(and (zero? (system* "tar" "xvf" source))
(zero? (system* "tar" "xvf" (string-append inner ".tar.gz")))
(chdir inner)
- (chdir "src"))))
+ (chdir "src")
+ ;; XXX The current patch system does not support unusual
+ ;; source unpack methods, so we have to apply this patch in a
+ ;; non-standard way.
+ (zero? (system* "patch" "-p1" "--batch" "-i"
+ (assoc-ref %build-inputs "patch/init-fix"))))))
(alist-replace
'check
(lambda* (#:key inputs #:allow-other-keys #:rest args)