summaryrefslogtreecommitdiff
path: root/gnu/packages/mingw.scm
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2020-03-24 17:19:33 -0400
committerCarl Dong <contact@carldong.me>2020-04-04 16:23:07 -0400
commit4719b715726303d680cd6f65caad96bfa194cda6 (patch)
tree49d31181e0f3e195000798ea46062dfabd43a388 /gnu/packages/mingw.scm
parent19b10c91e82a64ef989adf8dcdff0a291ca0675b (diff)
downloadpatches-4719b715726303d680cd6f65caad96bfa194cda6.tar
patches-4719b715726303d680cd6f65caad96bfa194cda6.tar.gz
gnu: mingw: Add mingw-w64 reproducibility patches.base-for-series-3439
These patches were originally found at the debian mingw-w64 team's mingw-w64 repo, and should improve the reproducibility of our mingw-w64 toolchain. * gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch: New file. * gnu/packages/patches/mingw-w64-reproducible-gendef.patch: New file. * gnu/local.mk (dist_patch_DATA): Update accordingly. * gnu/packages/mingw.scm (make-mingw-w64): Apply patches.
Diffstat (limited to 'gnu/packages/mingw.scm')
-rw-r--r--gnu/packages/mingw.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/mingw.scm b/gnu/packages/mingw.scm
index d0785c5067..b37f6c69bd 100644
--- a/gnu/packages/mingw.scm
+++ b/gnu/packages/mingw.scm
@@ -53,7 +53,10 @@ specified, recurse and return a mingw-w64 with support for winpthreads."
"mingw-w64-release/mingw-w64-v" version ".tar.bz2"))
(sha256
(base32 "0a5njsa2zw2ssdz10jkb10mhrf3cb8qp9avs89zqmw4n6pzxy85a"))
- (patches (search-patches "mingw-w64-6.0.0-gcc.patch"))))
+ (patches
+ (search-patches "mingw-w64-6.0.0-gcc.patch"
+ "mingw-w64-dlltool-temp-prefix.patch"
+ "mingw-w64-reproducible-gendef.patch"))))
(native-inputs `(("xgcc-core" ,(if xgcc xgcc (cross-gcc triplet)))
("xbinutils" ,(if xbinutils xbinutils (cross-binutils triplet)))
,@(if with-winpthreads?