summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-04-30 19:21:46 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-06 10:09:10 +0200
commit09270a97d9297e8acf6d9ff224dd1d58e2a4498e (patch)
tree684ea4cb1a945d8cf284555b3bd1d41e30a0d75f /gnu/packages/messaging.scm
parentcae491ab02e6e666f7108c1c851d845f7711bfa8 (diff)
downloadpatches-09270a97d9297e8acf6d9ff224dd1d58e2a4498e.tar
patches-09270a97d9297e8acf6d9ff224dd1d58e2a4498e.tar.gz
gnu: hexchat: Update to 2.12.4.
* gnu/packages/messaging.scm (hexchat): Update to 2.12.4. [source]: Remove incorrectly bootstrapped files. [native-inputs]: Add autoconf, autoconf-archive, automake, libtool, pkg-config. [arguments]: Add ‘bootstrap’ phase.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm35
1 files changed, 30 insertions, 5 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 9e45b7ad0f..6bd626d78c 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2014 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2014, 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
@@ -166,17 +166,35 @@ identi.ca and status.net).")
(define-public hexchat
(package
(name "hexchat")
- (version "2.12.2")
+ (version "2.12.4")
(source (origin
(method url-fetch)
(uri (string-append "https://dl.hexchat.net/hexchat/hexchat-"
version ".tar.xz"))
(sha256
(base32
- "1xnclfbrgbkqndxygi5f27q00jd7yy54jbd1061jmhxa6wzpibbd"))))
+ "0ficrx56knz5y297qb0x5y02339yvyv734z7kpcx1ixvb0qr2dgs"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Delete dangling symlinks to a non-existent ‘/usr’.
+ (with-directory-excursion "m4"
+ (for-each (lambda (f) (delete-file f))
+ '("intltool.m4" "libtool.m4" "lt~obsolete.m4"
+ "ltoptions.m4" "ltsugar.m4" "ltversion.m4")))
+ (delete-file-recursively "build-aux")
+ (delete-file "po/Makefile.in.in")
+ ;; This file is still required for autoreconf.
+ (copy-file (string-append (assoc-ref inputs "intltool")
+ "/share/intltool/Makefile.in.in")
+ "po/Makefile.in.in")))))
(build-system gnu-build-system)
- (native-inputs `(("pkg-config" ,pkg-config)
- ("intltool" ,intltool)))
+ (native-inputs `(("autoconf" ,autoconf)
+ ("autoconf-archive" ,autoconf-archive)
+ ("automake" ,automake)
+ ("intltool" ,intltool)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
(inputs `(("dbus-glib" ,dbus-glib)
("dbus" ,dbus)
("enchant" ,enchant)
@@ -190,6 +208,13 @@ identi.ca and status.net).")
("luajit" ,luajit)
("perl-xml-parser" ,perl-xml-parser)
("python-2" ,python-2)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Release 2.12.4 wasn't properly bootstrapped. Later ones might be!
+ (add-after 'unpack 'bootstrap
+ (lambda* (#:key inputs #:allow-other-keys)
+ (zero? (system* "autoreconf" "-fiv")))))))
(synopsis "Graphical IRC Client")
(description
"HexChat lets you connect to multiple IRC networks at once. The main