summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2017-01-18 12:34:24 +0000
committerMarius Bakke <mbakke@fastmail.com>2017-01-18 20:24:16 +0100
commitfdfb4b96044859198e0d16a05d42d4db08c02dd7 (patch)
tree7557df67a19f209f5415ff76a54d519175288846 /gnu/packages/messaging.scm
parent395751c05d589c6f905822e02d124767f6fe0259 (diff)
downloadpatches-fdfb4b96044859198e0d16a05d42d4db08c02dd7.tar
patches-fdfb4b96044859198e0d16a05d42d4db08c02dd7.tar.gz
gnu: Add loudmouth.
* gnu/packages/messaging.scm (loudmouth): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm34
1 files changed, 33 insertions, 1 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 2be3b09695..cded33a1ed 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016 ng0 <ng0@libertad.pw>
+;;; Copyright © 2016, 2017 <contact.ng0@cryptolab.net>
;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2016, 2017 Clément Lassieur <clement@lassieur.org>
;;;
@@ -1120,4 +1120,36 @@ Conferencing (PSYC). psycLPC is a fork of LDMud with some new features and
many bug fixes.")
(license license:gpl2))))
+(define-public loudmouth
+ (package
+ (name "loudmouth")
+ (version "1.5.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://mcabber.com/files/loudmouth/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0b6kd5gpndl9nzis3n6hcl0ldz74bnbiypqgqa1vgb0vrcar8cjl"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("glib" ,glib)
+ ("gnutls" ,gnutls)
+ ("libidn" ,libidn)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("check" ,check)
+ ("glib" ,glib "bin") ; gtester
+ ("gtk-doc" ,gtk-doc)))
+ (home-page "https://mcabber.com/")
+ (description
+ "Loudmouth is a lightweight and easy-to-use C library for programming
+with the XMPP (formerly known as Jabber) protocol. It is designed to be
+easy to get started with and yet extensible to let you do anything the XMPP
+protocol allows.")
+ (synopsis "Asynchronous XMPP library")
+ ;; The files have LGPL2.0+ headers, but COPYING specifies LGPL2.1.
+ (license license:lgpl2.0+)))
+
;;; messaging.scm ends here