summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-04-30 04:03:54 -0400
committerMark H Weaver <mhw@netris.org>2018-04-30 04:03:54 -0400
commit3d5ad159b336a9903b31d0be7ae052dbc8d5bfcc (patch)
treeee7dce4e436490a1db5f18e4bfad55511d2fff32 /gnu/packages/messaging.scm
parentc77835db04ee20c0afe20600dc8f91a67bc2421e (diff)
parent8c21c64e59d3f4d223d8aeef91f06fdde7de1ab7 (diff)
downloadpatches-3d5ad159b336a9903b31d0be7ae052dbc8d5bfcc.tar
patches-3d5ad159b336a9903b31d0be7ae052dbc8d5bfcc.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm36
1 files changed, 21 insertions, 15 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index b3205c7ae2..c31e3604c8 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -802,7 +802,7 @@ protocols.")
(define-public c-toxcore
(package
(name "c-toxcore")
- (version "0.1.11")
+ (version "0.2.2")
(source
(origin
(method url-fetch)
@@ -811,7 +811,10 @@ protocols.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "040vwihl1r5159vzimmnff75iqfg53vhnfi5wcb3cd0c2r51idl5"))))
+ "18bfqx0ylbas9gs91rkspf04l5fjjcl0mxm1gfs2d59bv65mvcm3"))))
+ (arguments
+ `(#:tests? #f)) ; FIXME: Testsuite seems to stay stuck on test 3. Disable
+ ; for now.
(build-system cmake-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -829,23 +832,26 @@ messenger protocol.")
(define-public utox
(package
(name "utox")
- (version "0.16.1")
+ (version "0.17.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/uTox/uTox/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/uTox/uTox.git")
+ (commit "v0.17.0")
+ (recursive? #t))) ;; Needed for 'minini' git submodule.
+ (file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "14xl72y4w1x2kk0cvkcr9pmywllm0r9w2grjqiknwn95pw6yxz6q"))))
+ "12wbq883il7ikldayh8hm0cjfrkp45vn05xx9s1jbfz6gmkidyar"))))
(build-system cmake-build-system)
(arguments
- `(#:phases
+ `(#:configure-flags '("-DENABLE_TESTS=on")
+ #:phases
(modify-phases %standard-phases
(add-before 'build 'patch-absolute-filename-libgtk-3
(lambda* (#:key inputs outputs #:allow-other-keys)
- (substitute* "../uTox-0.16.1/src/xlib/gtk.c"
+ (substitute* "../source/src/xlib/gtk.c"
(("libgtk-3.so")
(string-append (assoc-ref inputs "gtk+")
"/lib/libgtk-3.so")))))
@@ -884,14 +890,14 @@ instant messenger with audio and video chat capabilities.")
(define-public qtox
(package
(name "qtox")
- (version "1.13.0")
+ (version "1.15.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/qTox/qTox/archive/v"
version ".tar.gz"))
(sha256
(base32
- "0dyplmlqhg4zbg7hdzp3iqppn9xgp7pds5k6w6byjcqhb9zv91ca"))
+ "0bmnx6m33qn9nx40yy268x4wnvv2y7bvm41hzrlbhsiaph7kg583"))
(file-name (string-append name "-" version ".tar.gz"))))
(build-system cmake-build-system)
(arguments
@@ -913,7 +919,7 @@ instant messenger with audio and video chat capabilities.")
,(list (string-append (assoc-ref inputs "qtsvg")
"/lib/qt5/plugins/"))))))))))
(inputs
- `(("ffmpeg" ,ffmpeg)
+ `(("ffmpeg" ,ffmpeg-3.4)
("filteraudio" ,filteraudio)
("glib" ,glib)
("gtk+" ,gtk+-2)
@@ -1520,14 +1526,14 @@ building the IRC clients and bots.")
(define-public toxic
(package
(name "toxic")
- (version "0.8.0")
+ (version "0.8.2")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/JFreegman/toxic/archive/v"
version ".tar.gz"))
(sha256
(base32
- "0166lqb47f4kj34mhi57aqmnk9mh4hsicmbdsj6ag54sy1zicy20"))
+ "1dx6z7k0zpsd7dpysdy23f0hnm49qlikb0mq8fg0y01dsz9vxgak"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments