summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2017-01-28 17:05:15 +0100
committerMathieu Lirzin <mthl@gnu.org>2017-01-28 22:22:03 +0100
commitc631233fd44fe6ea32197fa21fda35fc864d0d2a (patch)
tree8a5ccfec1d8c477a99641b23dbbb761041590c32 /gnu/packages/messaging.scm
parent09e353d846e2bb838e1c07e40bc1de35c85ea7d7 (diff)
downloadpatches-c631233fd44fe6ea32197fa21fda35fc864d0d2a.tar
patches-c631233fd44fe6ea32197fa21fda35fc864d0d2a.tar.gz
gnu: Add GNU Freetalk.
* gnu/packages/messaging.scm (freetalk): New variable. Signed-off-by: Mathieu Lirzin <mthl@gnu.org>
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm59
1 files changed, 58 insertions, 1 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 5b3ed740d9..bd7e2bfa06 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -78,7 +78,12 @@
#:use-module (gnu packages xiph)
#:use-module (gnu packages audio)
#:use-module (gnu packages bison)
- #:use-module (gnu packages fontutils))
+ #:use-module (gnu packages fontutils)
+ #:use-module (gnu packages bash)
+ #:use-module (gnu packages guile)
+ #:use-module (gnu packages less)
+ #:use-module (gnu packages readline)
+ #:use-module (gnu packages texinfo))
(define-public libotr
(package
@@ -1188,4 +1193,56 @@ support, and more.")
(synopsis "Small XMPP console client")
(license license:gpl2+)))
+(define-public freetalk
+ (package
+ (name "freetalk")
+ (version "4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/freetalk/freetalk-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1rmrn7a1bb7vm26yaklrvx008a9qhwc32s57dwrlf40lv9gffwny"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'autogen
+ (lambda _
+ (zero? (system* "sh" "autogen.sh"))))
+ ;; For 'system' commands in Scheme code.
+ (add-after 'install 'wrap-program
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bash (assoc-ref inputs "bash"))
+ (coreutils (assoc-ref inputs "coreutils"))
+ (less (assoc-ref inputs "less")))
+ (wrap-program (string-append out "/bin/freetalk")
+ `("PATH" ":" prefix
+ ,(map (lambda (dir)
+ (string-append dir "/bin"))
+ (list bash coreutils less))))
+ #t))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)))
+ (inputs
+ `(("bash" ,bash)
+ ("glib" ,glib)
+ ("guile" ,guile-2.0)
+ ("less" ,less)
+ ("loudmouth" ,loudmouth)
+ ("readline" ,readline)))
+ (synopsis "Extensible console-based Jabber client")
+ (description
+ "GNU Freetalk is a command-line Jabber/XMPP chat client. It notably uses
+the Readline library to handle input, so it features convenient navigation of
+text as well as tab-completion of buddy names, commands and English words. It
+is also scriptable and extensible via Guile.")
+ (home-page "https://www.gnu.org/software/freetalk")
+ (license license:gpl3+)))
+
;;; messaging.scm ends here