summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-08-31 12:18:53 +0200
committerAndreas Enge <andreas@enge.fr>2013-08-31 12:18:53 +0200
commit71e0f28856558a1c8da76ab55689a3d7a29acd5a (patch)
treefb6422f45ade1acd57045a2e18008adc0a3e2d33 /gnu/packages/maths.scm
parentc8c871d184b66212cfacf1c0de16ee799f40fdd9 (diff)
downloadpatches-71e0f28856558a1c8da76ab55689a3d7a29acd5a.tar
patches-71e0f28856558a1c8da76ab55689a3d7a29acd5a.tar.gz
gnu: gsl: Disable numerically unstable test on i686.
* gnu/packages/maths.scm (gsl): Disable test.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index a2bb2a450e..75354122b5 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -79,6 +79,19 @@ the standard data file.")
(base32
"18qf6jzz1r3mzb5qynywv4xx3z9g61hgkbpkdrhbgqh2g7jhgfc5"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (alist-replace
+ 'configure
+ (lambda* (#:key target system outputs #:allow-other-keys #:rest args)
+ (let ((configure (assoc-ref %standard-phases 'configure)))
+ ;; disable numerically unstable test on i686, see thread at
+ ;; http://lists.gnu.org/archive/html/bug-gsl/2011-11/msg00019.html
+ (if (string=? (or target system) "i686-linux")
+ (substitute* "ode-initval2/Makefile.in"
+ (("TESTS = \\$\\(check_PROGRAMS\\)") "TESTS =")))
+ (apply configure args)))
+ %standard-phases)))
(home-page "http://www.gnu.org/software/gsl/")
(synopsis "Numerical library for C and C++")
(description