summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2019-02-21 21:01:26 -0600
committerEric Bavier <bavier@member.fsf.org>2019-02-21 22:04:48 -0600
commit5855756c81041bd7dd81ae45f473e1c116e2a0f2 (patch)
tree64b37e1cdf4f1cc37ebbdf5358a2c0bd4763e395 /gnu/packages/maths.scm
parentb8f9e97da8d44d3147c0f8f0f73ed924beef0186 (diff)
downloadpatches-5855756c81041bd7dd81ae45f473e1c116e2a0f2.tar
patches-5855756c81041bd7dd81ae45f473e1c116e2a0f2.tar.gz
gnu: openblas: Honor parallel-job-count.
* gnu/packages/maths.scm (openblas)[arguments]: Add "MAKE_NB_JOBS" make flag.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 7a03036b67..c3587007df 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2956,6 +2956,7 @@ parts of it.")
#:make-flags
(list (string-append "PREFIX=" (assoc-ref %outputs "out"))
"SHELL=bash"
+ "MAKE_NB_JOBS=0" ;use jobserver for submakes
;; Build the library for all supported CPUs. This allows
;; switching CPU targets at runtime with the environment variable
;; OPENBLAS_CORETYPE=<type>, where "type" is a supported CPU type.