summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-01-26 13:03:20 +0100
committerAndreas Enge <andreas@enge.fr>2014-01-26 13:04:03 +0100
commit566146abba4626bc02816118dd80bae68b8497d5 (patch)
treeb17af85bd2d3ae76656b59c58e5905688677f98e /gnu/packages/maths.scm
parent22f33e6112c2e58cf2f544296d6173b9b7ad49cb (diff)
downloadpatches-566146abba4626bc02816118dd80bae68b8497d5.tar
patches-566146abba4626bc02816118dd80bae68b8497d5.tar.gz
gnu: lapack: Update to 3.5.0.
* gnu/packages/maths.scm (lapack): Update to 3.5.0.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 640d502783..8844b4c7ba 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -163,7 +163,7 @@ output in text, PostScript, PDF or HTML.")
(define-public lapack
(package
(name "lapack")
- (version "3.4.2")
+ (version "3.5.0")
(source
(origin
(method url-fetch)
@@ -171,16 +171,7 @@ output in text, PostScript, PDF or HTML.")
version ".tgz"))
(sha256
(base32
- "1w7sf8888m7fi2kyx1fzgbm22193l8c2d53m8q1ibhvfy6m5v9k0"))
- (snippet
- ;; Remove non-free files.
- ;; See <http://icl.cs.utk.edu/lapack-forum/archives/lapack/msg01383.html>.
- '(for-each (lambda (file)
- (format #t "removing '~a'~%" file)
- (delete-file file))
- '("lapacke/example/example_DGESV_rowmajor.c"
- "lapacke/example/example_ZGESV_rowmajor.c"
- "DOCS/psfig.tex")))))
+ "0lk3f97i9imqascnlf6wr5mjpyxqcdj73pgj97dj2mgvyg9z1n4s"))))
(build-system cmake-build-system)
(home-page "http://www.netlib.org/lapack/")
(inputs `(("fortran" ,gfortran-4.8)