aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-02-26 22:37:12 +0100
committerLudovic Courtès <ludo@gnu.org>2015-02-26 22:37:12 +0100
commit93be4e8e6c6b82a5825b56cce991563bf19aaaf2 (patch)
tree2b48c1c88f046ee6e1d59636d1f6e8fbbd1660c2 /gnu/packages/maths.scm
parenta068dba78bde9c83a69c755df1131c286d065850 (diff)
parente1509174957bd9eba777bec86ea290fb44a4bce3 (diff)
downloadpatches-93be4e8e6c6b82a5825b56cce991563bf19aaaf2.tar
patches-93be4e8e6c6b82a5825b56cce991563bf19aaaf2.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index c3cf30c7a7..8c4eb3bd2f 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2014 Mathieu Lirzin <mathieu.lirzin@openmailbox.org>
+;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -212,6 +213,30 @@ can be imported from spreadsheets, text files and database sources and it can
be output in text, PostScript, PDF or HTML.")
(license license:gpl3+)))
+(define-public arpack-ng
+ (package
+ (name "arpack-ng")
+ (version "3.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/opencollab/arpack-ng/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1fwch6vipms1ispzg2djvbzv5wag36f1dmmr3xs3mbp6imfyhvff"))))
+ (build-system gnu-build-system)
+ (home-page "https://github.com/opencollab/arpack-ng")
+ (inputs
+ `(("lapack" ,lapack)
+ ("fortran" ,gfortran-4.8)))
+ (synopsis "Fortran subroutines for solving eigenvalue problems")
+ (description
+ "ARPACK-NG is a collection of Fortran77 subroutines designed to solve
+large scale eigenvalue problems.")
+ (license (license:bsd-style "file://COPYING"
+ "See COPYING in the distribution."))))
+
(define-public lapack
(package
(name "lapack")