summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-07-08 18:50:48 -0400
committerKei Kebreau <kei@openmailbox.org>2017-07-25 07:58:46 -0400
commit6b2eafaaa81cddc66c128a0aeeee99ed33cfb4ca (patch)
tree12f0e162750b1231a23dfddc68850de4929af66d /gnu/packages/maths.scm
parent5ea8dbf0c906d51779ba0cf775ec9967f5f42382 (diff)
downloadpatches-6b2eafaaa81cddc66c128a0aeeee99ed33cfb4ca.tar
patches-6b2eafaaa81cddc66c128a0aeeee99ed33cfb4ca.tar.gz
Revert "gnu: maxima: Ensure gcc is available at runtime."
This reverts commit f2fa86cc82b5941bde63b666337eea59aa609e55. Commit 5ea8dbf0c906d51779ba0cf775ec9967f5f42382 fixes the underlying issue in GNU Common Lisp.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm71
1 files changed, 31 insertions, 40 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index f8967cd944..91a092d569 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2075,8 +2075,7 @@ to BMP, JPEG or PNG image formats.")
(patches (search-patches "maxima-defsystem-mkdir.patch"))))
(build-system gnu-build-system)
(inputs
- `(("gcc" ,gcc)
- ("gcl" ,gcl)
+ `(("gcl" ,gcl)
("gnuplot" ,gnuplot) ;for plots
("tk" ,tk))) ;Tcl/Tk is used by 'xmaxima'
(native-inputs
@@ -2098,44 +2097,36 @@ to BMP, JPEG or PNG image formats.")
;; '/tmp/nix-build-maxima-*', which won't exist at run time.
;; Work around that.
#:make-flags (list "TMPDIR=/tmp")
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'set-gcc-path
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "lisp-utils/defsystem.lisp"
- (("\\(defparameter \\*c-compiler\\* \"gcc\"\\)")
- (string-append "(defparameter *c-compiler* \""
- (assoc-ref inputs "gcc") "/bin/gcc\")")))
- #t))
- (add-before 'check 'pre-check
- (lambda _
- (chmod "src/maxima" #o555)
- #t))
- ;; Make sure the doc and emacs files are found in the
- ;; standard location. Also configure maxima to find gnuplot
- ;; without having it on the PATH.
- (add-after 'install 'post-install
- (lambda* (#:key outputs inputs #:allow-other-keys)
- (let* ((gnuplot (assoc-ref inputs "gnuplot"))
- (out (assoc-ref outputs "out"))
- (datadir (string-append out "/share/maxima/" ,version)))
- (with-directory-excursion out
- (mkdir-p "share/emacs")
- (mkdir-p "share/doc")
- (symlink
- (string-append datadir "/emacs/")
- (string-append out "/share/emacs/site-lisp"))
- (symlink
- (string-append datadir "/doc/")
- (string-append out "/share/doc/maxima"))
- (with-atomic-file-replacement
- (string-append datadir "/share/maxima-init.lisp")
- (lambda (in out)
- (format out "~a ~s~a~%"
- "(setf $gnuplot_command "
- (string-append gnuplot "/bin/gnuplot") ")")
- (dump-port in out)))))
- #t)))))
+ #:phases (alist-cons-before
+ 'check 'pre-check
+ (lambda _
+ (chmod "src/maxima" #o555))
+ ;; Make sure the doc and emacs files are found in the
+ ;; standard location. Also configure maxima to find gnuplot
+ ;; without having it on the PATH.
+ (alist-cons-after
+ 'install 'post-install
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ (let* ((gnuplot (assoc-ref inputs "gnuplot"))
+ (out (assoc-ref outputs "out"))
+ (datadir (string-append out "/share/maxima/" ,version)))
+ (with-directory-excursion out
+ (mkdir-p "share/emacs")
+ (mkdir-p "share/doc")
+ (symlink
+ (string-append datadir "/emacs/")
+ (string-append out "/share/emacs/site-lisp"))
+ (symlink
+ (string-append datadir "/doc/")
+ (string-append out "/share/doc/maxima"))
+ (with-atomic-file-replacement
+ (string-append datadir "/share/maxima-init.lisp")
+ (lambda (in out)
+ (format out "~a ~s~a~%"
+ "(setf $gnuplot_command "
+ (string-append gnuplot "/bin/gnuplot") ")")
+ (dump-port in out))))))
+ %standard-phases))))
(home-page "http://maxima.sourceforge.net")
(synopsis "Numeric and symbolic expression manipulation")
(description "Maxima is a system for the manipulation of symbolic and