summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-07-07 22:58:27 -0400
committerKei Kebreau <kei@openmailbox.org>2017-07-08 17:05:55 -0400
commit5143517c9969d17b48cbb60e1103633bc0cfb430 (patch)
tree519fa29c381bbea49c5b71740e7aaaed7b4e9189 /gnu/packages/maths.scm
parentfac2b430b95008a5835a8a1aa94c6f570469ae63 (diff)
downloadpatches-5143517c9969d17b48cbb60e1103633bc0cfb430.tar
patches-5143517c9969d17b48cbb60e1103633bc0cfb430.tar.gz
gnu: wxmaxima: Update to 17.05.0.
* gnu/packages/maths.scm (wxmaxima): Update to 17.05.0. [source]: Update URL and add file-name. [native-inputs]: Add autoconf, automake and gettext-minimal. [arguments]: Add 'autoconf' phase.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm20
1 files changed, 14 insertions, 6 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index a0fcb6a443..1bf049fc4c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -48,6 +48,7 @@
#:use-module (guix build-system ocaml)
#:use-module (guix build-system r)
#:use-module (gnu packages algebra)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
@@ -2151,18 +2152,21 @@ point numbers.")
(define-public wxmaxima
(package
(name "wxmaxima")
- ;; Versions 16.12.0 to 16.12.2 have a bug which causes output lines to
- ;; overlap. See <https://debbugs.gnu.org/25793>
- (version "16.04.2")
+ (version "17.05.0")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://sourceforge/wxmaxima/wxMaxima/"
- version "/" name "-" version ".tar.gz"))
+ (uri (string-append "https://github.com/andrejv/" name "/archive"
+ "/Version-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1fpqzk1921isiqrpgpf433ldq41924qs9sy99fl1zn5661b2l73n"))))
+ "1bsyd7r12xm2crpizb9iyyki3j0mbazzzwbsh871m06dv2wk97gq"))))
(build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gettext" ,gettext-minimal)))
(inputs
`(("wxwidgets" ,wxwidgets)
("maxima" ,maxima)
@@ -2172,6 +2176,10 @@ point numbers.")
("shared-mime-info" ,shared-mime-info)))
(arguments
`(#:phases (modify-phases %standard-phases
+ (add-before
+ 'configure 'autoconf
+ (lambda _
+ (zero? (system* "./bootstrap"))))
(add-after
'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)